SAML 2.0
Official docs outline
7 sections- Technical overview
Overview of identity providers, service providers, assertions and protocols.
- Assertions and protocols (core)
Assertion, subject, conditions, authentication statements, request/response protocols.
- Bindings
HTTP Redirect, HTTP POST, HTTP Artifact and SOAP bindings.
- Profiles
Web Browser SSO, single logout and artifact resolution profiles.
- Metadata
Entity descriptors, endpoints and certificates exchanged between parties.
- Authentication context
Authentication context classes describing how users authenticated.
- Security and privacy considerations
Signature wrapping, replay, message confidentiality and privacy.
Each section links to the official page. Titles and summaries by Extra Credit; the docs belong to their authors.
More in Auth and identity
All 21- OAuth 2.0 (RFC 6749)
- OAuth 2.0 Bearer Token Usage (RFC 6750)
- OAuth 2.0 Device Authorization Grant (RFC 8628)
- OAuth 2.0 Security Best Current Practice (RFC 9700)
- OAuth 2.0 Token Exchange (RFC 8693)
- OAuth 2.1 (IETF draft)
- OpenID Connect Core 1.0
- Passkeys
- PKCE (RFC 7636)
- SCIM 2.0 (RFC 7643 and 7644)
- TOTP and HOTP (RFC 6238 and 4226)
- WebAuthn (W3C Web Authentication Level 3)