OAuth 2.0 Device Authorization Grant (RFC 8628)
Official docs outline
6 sections- Device authorization request
Requesting a device_code and user_code.
- Device authorization response
verification_uri, expires_in and polling interval.
- User interaction
Entering the user code on a secondary device.
- Device access token request
Polling the token endpoint with the device_code grant type.
- Device access token response
authorization_pending, slow_down and access_denied errors.
- Security considerations
Brute forcing user codes and remote phishing.
Each section links to the official page. Titles and summaries by Extra Credit; the docs belong to their authors.
More in Auth and identity
All 21- JSON Web Signature (RFC 7515)
- JSON Web Token (RFC 7519)
- Kerberos V5 (RFC 4120)
- LDAP (RFC 4510 series)
- OAuth 2.0 (RFC 6749)
- OAuth 2.0 Bearer Token Usage (RFC 6750)
- OAuth 2.0 Security Best Current Practice (RFC 9700)
- OAuth 2.0 Token Exchange (RFC 8693)
- OAuth 2.1 (IETF draft)
- OpenID Connect Core 1.0
- Passkeys
- PKCE (RFC 7636)