FIDO2 CTAP 2.1
- Category
- Auth and identity
- Docs outline
- 8 sections
Official docs outline
fidoalliance.org- Authenticator API
CTAP2 command overview over CBOR messages.
- authenticatorMakeCredential
Creating a new credential, options and attestation response.
- authenticatorGetAssertion
Generating an assertion for a relying party.
- authenticatorGetInfo
Discovering authenticator versions, options and extensions.
- authenticatorClientPIN
PIN protocols and PIN/UV auth tokens.
- authenticatorCredentialManagement
Enumerating and deleting discoverable credentials.
- authenticatorLargeBlobs
Storing large blobs associated with credentials.
- authenticatorConfig
Configuring authenticator settings like enterprise attestation.
Each section links to the official page. Titles and summaries by Extra Credit; the docs belong to their authors.
More in Auth and identity
All 21- DPoP (RFC 9449)
- JSON Web Encryption (RFC 7516)
- JSON Web Key and Algorithms (RFC 7517 and 7518)
- JSON Web Signature (RFC 7515)
- JSON Web Token (RFC 7519)
- Kerberos V5 (RFC 4120)
- LDAP (RFC 4510 series)
- OAuth 2.0 (RFC 6749)
- OAuth 2.0 Bearer Token Usage (RFC 6750)
- OAuth 2.0 Device Authorization Grant (RFC 8628)
- OAuth 2.0 Security Best Current Practice (RFC 9700)
- OAuth 2.0 Token Exchange (RFC 8693)