Go modules
5,000 in Packages and libraries, most used first. Page 5 of 25.
-
github.com/go-gl/glfw/v3.3/glfw
-
github.com/google/wire Package wire contains directives for Wire code generation.
-
github.com/apparentlymart/go-cidr
-
github.com/stoewer/go-strcase Package strcase converts between different kinds of naming formats such as camel case (CamelCase), snake case (snake_case) or kebab case (ke
-
go.uber.org/automaxprocs Package automaxprocs automatically sets GOMAXPROCS to match the Linux container CPU quota, if any.
-
github.com/keybase/go-keychain
-
github.com/fatih/camelcase Package camelcase is a micro package to split the words of a camelcase type string into a slice of words.
-
github.com/pkg/sftp Package sftp implements the SSH File Transfer Protocol as described in https://filezilla-project.org/specs/draft-ietf-secsh-filexfer-02.txt
-
github.com/jcmturner/gokrb5/v8 Package gokrb5 provides a Kerberos 5 implementation for Go.
-
github.com/francoispqt/gojay Package gojay implements encoding and decoding of JSON as defined in RFC 7159.
-
github.com/multiformats/go-base36 Package base36 provides a reasonably fast implementation of a binary base36 codec.
-
lukechampine.com/blake3 Package blake3 implements the BLAKE3 cryptographic hash function.
-
github.com/disintegration/imaging Package imaging provides basic image processing functions (resize, rotate, crop, brightness/contrast adjustments, etc.).
-
github.com/magefile/mage Package main is the entry point for the mage binary.
-
github.com/containerd/stargz-snapshotter/estargz
-
gopkg.in/fsnotify.v1 Package fsnotify provides a platform-independent interface for file system notifications.
-
github.com/consensys/gnark-crypto
-
github.com/tendermint/btcd btcd is a full-node bitcoin implementation written in Go.
-
github.com/cosmos/gogoproto
-
github.com/holiman/bloomfilter/v2
-
github.com/hashicorp/terraform-plugin-sdk/v2
-
github.com/knadh/koanf
-
github.com/cockroachdb/apd/v2 Package apd implements arbitrary-precision decimals.
-
github.com/gorilla/css
-
cloud.google.com/go/longrunning
-
gopkg.in/urfave/cli.v1 Package cli provides a minimal framework for creating and organizing command line Go applications.
-
github.com/pjbgf/sha1cd Package sha1cd implements collision detection based on the whitepaper Counter-cryptanalysis from Marc Stevens.
-
github.com/ipfs/go-log/v2 Package log is the logging library used by IPFS & libp2p (https://github.com/ipfs/go-ipfs).
-
github.com/vmihailenco/tagparser
-
github.com/skeema/knownhosts Package knownhosts is a thin wrapper around golang.org/x/crypto/ssh/knownhosts, adding the ability to obtain the list of host key algorithms
-
github.com/briandowns/spinner Package spinner is a simple package to add a spinner / progress indicator to any terminal application.
-
github.com/Masterminds/squirrel Package squirrel provides a fluent SQL generator.
-
github.com/antlr/antlr4/runtime/Go/antlr
-
github.com/cespare/cp Package cp offers simple file and directory copying for Go.
-
cosmossdk.io/math Package math implements custom Cosmos SDK math types used for arithmetic operations.
-
github.com/gorilla/schema Package gorilla/schema fills a struct with form values.
-
github.com/distribution/reference Package reference provides a general type to represent any way of referencing images within the registry.
-
github.com/mattn/go-shellwords
-
github.com/deckarep/golang-set/v2 Package mapset implements a simple and set collection.
-
github.com/aead/chacha20 Package chacha20 implements the ChaCha20 / XChaCha20 stream chipher.
-
github.com/ipfs/go-datastore
-
cosmossdk.io/errors
-
github.com/vektah/gqlparser/v2
-
github.com/labstack/echo Package echo implements high performance, minimalist Go web framework.
-
github.com/jcmturner/dnsutils/v2
-
github.com/jcmturner/aescts/v2 Package aescts provides AES CBC CipherText Stealing encryption and decryption methods
-
github.com/cheggaaa/pb Simple console progress bars
-
github.com/xi2/xz
-
github.com/dgraph-io/badger Package badger implements an embeddable, simple and fast key-value database, written in pure Go.
-
github.com/antchfx/htmlquery Package htmlquery provides extract data from HTML documents using XPath expression.
-
github.com/natefinch/lumberjack Package lumberjack provides a rolling logger.
-
github.com/aws/aws-sdk-go-v2/feature/s3/manager Package manager provides utilities to upload and download objects from S3 concurrently.
-
github.com/marten-seemann/qtls-go1-18 package qtls partially implements TLS 1.2, as specified in RFC 5246, and TLS 1.3, as specified in RFC 8446.
-
github.com/swaggo/gin-swagger
-
github.com/karrick/godirwalk Package godirwalk provides functions to read and traverse directory trees.
-
github.com/go-redis/redis/v7 Package redis implements a Redis client.
-
github.com/xdg/scram Package scram is deprecated in favor of xdg-go/scram.
-
github.com/Knetic/govaluate
-
github.com/xdg/stringprep Package stringprep provides data tables and algorithms for RFC-3454, including errata (as of 2018-02).
-
modernc.org/strutil Package strutil collects utils supplemental to the standard strings package.
-
github.com/jcmturner/rpc/v2
-
github.com/alibabacloud-go/tea
-
github.com/hpcloud/tail
-
github.com/redis/go-redis/v9 Package redis implements a Redis client.
-
github.com/fxamacker/cbor/v2 Package cbor is a modern CBOR codec (RFC 8949 & RFC 8742) with CBOR tags, Go struct tag options (toarray/keyasint/omitempty/omitzero), Core
-
github.com/ipfs/go-ipfs-util Package util implements various utility functions used within ipfs that do not currently have a better place to live.
-
github.com/lestrrat-go/file-rotatelogs package rotatelogs is a port of File-RotateLogs from Perl (https://metacpan.org/release/File-RotateLogs), and it allows you to automatically
-
go.uber.org/dig Package dig provides an opinionated way of resolving object dependencies.
-
github.com/containerd/typeurl
-
github.com/Azure/azure-sdk-for-go/sdk/storage/azblob
-
github.com/pkg/profile Package profile provides a simple way to manage runtime/pprof profiling of your Go application.
-
github.com/lann/builder Package builder provides a method for writing fluent immutable builders.
-
gopkg.in/gomail.v2 Package gomail provides a simple interface to compose emails and to mail them efficiently.
-
github.com/moby/sys/mount Package mount provides a set of functions to mount and unmount mounts.
-
go.uber.org/fx Package fx is a framework that makes it easy to build applications out of reusable, composable modules.
-
github.com/goccy/go-yaml
-
github.com/hashicorp/terraform-json
-
github.com/VividCortex/gohistogram Package gohistogram contains implementations of weighted and exponential histograms.
-
github.com/ajg/form Package form implements encoding and decoding of application/x-www-form-urlencoded data.
-
github.com/golangci/revgrep Package revgrep filter static analysis tools to only lines changed based on a commit reference.
-
gopkg.in/gemnasium/logrus-airbrake-hook.v2
-
github.com/xo/terminfo Package terminfo implements reading terminfo files in pure go.
-
github.com/lann/ps Fully persistent data structures.
-
github.com/AndreasBriese/bbloom
-
github.com/go-critic/go-critic nolint // it's not a Go code file
-
github.com/antchfx/xmlquery Package xmlquery provides extract data from XML documents using XPath expression.
-
github.com/golangci/lint-1 Package lint contains a linter for Go source code.
-
gopkg.in/airbrake/gobrake.v2
-
gopkg.in/go-playground/validator.v8 Package validator implements value validations for structs and individual fields based on tags.
-
github.com/nwaples/rardecode
-
github.com/kr/fs Package fs provides filesystem-related functions.
-
go.opentelemetry.io/collector
-
go.opentelemetry.io/contrib Package contrib is a collection of extensions for the opentelemetry-go project.
-
github.com/vmihailenco/msgpack/v4
-
github.com/graph-gophers/graphql-go
-
github.com/gordonklaus/ineffassign
-
github.com/gdamore/tcell/v2 Package tcell provides a lower-level, portable API for building programs that interact with terminals or consoles.
-
github.com/minio/minio-go/v7
-
github.com/samber/lo
-
github.com/grpc-ecosystem/grpc-opentracing
-
github.com/codahale/hdrhistogram Package hdrhistogram provides an implementation of Gil Tene's HDR Histogram data structure.
-
github.com/muesli/ansi
-
github.com/cheggaaa/pb/v3
-
github.com/ettle/strcase Package strcase is a package for converting strings into various word cases (e.g.
-
github.com/swaggo/files
-
github.com/saintfish/chardet Package chardet ports character set detection from ICU.
-
github.com/moby/locker Package locker provides a mechanism for creating finer-grained locking to help free up more global locks to handle other tasks.
-
github.com/kisielk/gotool Package gotool contains utility functions used to implement the standard "cmd/go" tool, provided as a convenience to developers who want to
-
github.com/minio/blake2b-simd Package blake2b implements BLAKE2b cryptographic hash function.
-
github.com/hashicorp/terraform
-
github.com/opencontainers/selinux
-
github.com/cometbft/cometbft-db
-
github.com/facebookgo/stack Package stack provides utilities to capture and pass around stack traces. This is useful for building errors that know where they originate
-
github.com/dgraph-io/badger/v3 Package badger implements an embeddable, simple and fast key-value database, written in pure Go.
-
github.com/shurcooL/httpfs
-
github.com/facebookgo/subset Package subset implements logic to check if a value is a subset of another using reflect.
-
github.com/facebookgo/ensure Package ensure provides utilities for testing to ensure the given conditions are met and Fatal if they aren't satisified.
-
github.com/hashicorp/terraform-svchost Package svchost deals with the representations of the so-called "friendly hostnames" that we use to represent systems that provide Terraform
-
github.com/nfnt/resize Package resize implements various image resizing methods.
-
github.com/gdamore/encoding Package encoding provides a few of the encoding structures that are missing from the Go x/text/encoding tree.
-
github.com/influxdata/line-protocol
-
github.com/fzipp/gocyclo Package gocyclo calculates the cyclomatic complexities of functions and methods in Go source code.
-
github.com/quic-go/qtls-go1-20 package qtls partially implements TLS 1.2, as specified in RFC 5246, and TLS 1.3, as specified in RFC 8446.
-
github.com/go-chi/cors cors package is net/http handler to handle CORS related requests as defined by http://www.w3.org/TR/cors/
-
github.com/VividCortex/ewma Package ewma implements exponentially weighted moving averages.
-
github.com/jbenet/goprocess Package goprocess introduces a Process abstraction that allows simple organization, and orchestration of work.
-
github.com/go-gl/gl
-
github.com/golangci/misspell Package misspell corrects commonly misspelled English words in source files.
-
github.com/containerd/ttrpc package ttrpc defines and implements a low level simple transfer protocol optimized for low latency and reliable connections between process
-
github.com/xanzy/go-gitlab
-
github.com/nbutton23/zxcvbn-go
-
github.com/robertkrimen/otto Package otto is a JavaScript parser and interpreter written natively in Go.
-
github.com/hashicorp/go-cty
-
modernc.org/ccgo/v3 Package ccgo translates C to Go source code. This v3 package is obsolete. Please use current ccgo/v4: Invocation 2021-12-23: v3.13.0 add
-
cloud.google.com/go/firestore
-
github.com/davidlazar/go-crypto
-
modernc.org/token Package token is variant of the stdlib package token with types FileSet and Token removed.
-
github.com/marten-seemann/qtls-go1-16 package qtls partially implements TLS 1.2, as specified in RFC 5246, and TLS 1.3, as specified in RFC 8446.
-
github.com/naoina/go-stringutil
-
github.com/quic-go/quic-go
-
github.com/vbatts/tar-split
-
github.com/tidwall/btree
-
github.com/naoina/toml Package toml encodes and decodes the TOML configuration format using reflection.
-
github.com/marten-seemann/qtls-go1-17 package qtls partially implements TLS 1.2, as specified in RFC 5246, and TLS 1.3, as specified in RFC 8446.
-
gopkg.in/cheggaaa/pb.v1 Simple console progress bars
-
4d63.com/gochecknoglobals
-
github.com/containerd/log Package log provides types and functions related to logging, passing loggers through a context, and attaching context to the logger.
-
github.com/karalabe/usb Package usb provide interfaces for generic USB devices.
-
github.com/Djarvur/go-err113 Package err113 is a Golang linter to check the errors handling expressions
-
github.com/prometheus/prometheus
-
retract
-
github.com/golangci/gofmt
-
github.com/segmentio/ksuid
-
github.com/multiformats/go-multiaddr-dns
-
github.com/alicebob/gopher-json Package json is a simple JSON encoder/decoder for gopher-lua.
-
github.com/savsgio/gotils
-
github.com/tidwall/sjson Package sjson provides setting json values.
-
howett.net/plist Package plist implements encoding and decoding of Apple's "property list" format.
-
github.com/multiformats/go-multistream Package multistream implements a simple stream router for the multistream-select protocoli.
-
github.com/cilium/ebpf Package ebpf is a toolkit for working with eBPF programs.
-
github.com/daixiang0/gci
-
github.com/hashicorp/terraform-plugin-go
-
github.com/mitchellh/colorstring colorstring provides functions for colorizing strings for terminal output.
-
github.com/chavacava/garif Package garif defines all the GO structures required to model a SARIF log file.
-
github.com/Azure/go-ntlmssp Protocol details from https://msdn.microsoft.com/en-us/library/cc236621.aspx, implementation hints from http://davenport.sourceforge.net/ntl
-
mvdan.cc/gofumpt gofumpt enforces a stricter format than gofmt, while being backwards compatible.
-
github.com/gobuffalo/packr/v2
-
gopkg.in/sourcemap.v1
-
github.com/beevik/etree Package etree provides XML services through an Element Tree abstraction.
-
gopkg.in/olebedev/go-duktape.v3
-
github.com/astaxie/beego Package beego provide a MVC framework beego: an open-source, high-performance, modular, full-stack web framework It is used for rapid develo
-
go.opentelemetry.io/otel/sdk/export/metric
-
github.com/muesli/cancelreader
-
github.com/multiformats/go-multicodec Package multicodec exposes the multicodec table as Go constants.
-
mvdan.cc/unparam unparam reports unused function parameters and results in your code.
-
sigs.k8s.io/controller-tools
-
github.com/googleapis/go-type-adapters
-
github.com/google/certificate-transparency-go Package ct holds core types and utilities for Certificate Transparency.
-
modernc.org/opt Package opt implements command-line flag parsing.
-
github.com/golangci/dupl
-
github.com/golangci/unconvert Package unconvert Unconvert removes redundant type conversions from Go packages.
-
github.com/chromedp/cdproto Package cdproto holds the types of the Chrome DevTools Protocol that no domain owns: the message that a connection sends and reads, the erro
-
github.com/golangci/go-misc
-
github.com/bombsimon/wsl/v3
-
github.com/segmentio/kafka-go
-
github.com/golangci/check
-
github.com/golangci/maligned
-
github.com/globalsign/mgo Package mgo (pronounced as "mango") offers a rich MongoDB driver for Go.
-
github.com/apparentlymart/go-textseg/v15
-
github.com/btcsuite/btcd/btcutil Package btcutil provides bitcoin-specific convenience functions and types.
-
github.com/etcd-io/bbolt package bbolt implements a low-level key/value store in pure Go.
-
github.com/tjfoc/gmsm
-
github.com/alecthomas/kong Package kong aims to support arbitrarily complex command-line structures with as little developer effort as possible.
-
github.com/pkg/term Package term manages POSIX terminals.
-
github.com/quic-go/qtls-go1-19 package qtls partially implements TLS 1.2, as specified in RFC 5246, and TLS 1.3, as specified in RFC 8446.
-
github.com/acarl005/stripansi
-
github.com/ashanbrown/makezero
-
github.com/caarlos0/env/v6
-
github.com/ashanbrown/forbidigo
-
github.com/quic-go/qpack