Cryptography
20 in Standards and protocols, most used first.
- ACME (RFC 8555)
- AES (FIPS 197) and Block Cipher Modes
- Argon2 (RFC 9106)
- bcrypt
- ChaCha20-Poly1305 (RFC 8439)
- ECDSA and Elliptic Curves (FIPS 186-5)
- Ed25519 and EdDSA (RFC 8032)
- HKDF (RFC 5869)
- HMAC (RFC 2104)
- OpenPGP (RFC 9580)
- PBKDF2 (RFC 8018)
- PKCS Standards
- Post-Quantum Cryptography (FIPS 203, 204, 205)
- RSA and PKCS #1 (RFC 8017)
- scrypt (RFC 7914)
- SHA-2 (FIPS 180-4)
- SHA-3 and Keccak (FIPS 202)
- Web Cryptography API
- X.509 Certificates (RFC 5280)
- X25519 and Curve25519 (RFC 7748)