Rust crates
4,945 in Packages and libraries, most used first. Page 3 of 25.
-
rand_xorshift Xorshift random number generator
-
tracing-serde A compatibility layer for serializing trace data with `serde`
-
pest_generator pest code generator
-
wasm-bindgen-backend Backend code generation of the wasm-bindgen tool
-
serde_repr Derive Serialize and Deserialize that delegates to the underlying repr of a C-like enum.
-
crypto-bigint Pure Rust implementation of a big integer library which has been designed from the ground-up for use in cryptographic applications. Provides
-
bitvec Addresses memory by bits, for packed collections and bitfields
-
tokio-native-tls An implementation of TLS/SSL streams for Tokio using native-tls giving an implementation of TLS for nonblocking I/O streams.
-
dirs A tiny low-level library that provides platform-specific standard locations of directories for config, cache and other data on Linux, Window
-
zeroize_derive Custom derive support for zeroize
-
brotli-decompressor A brotli decompressor that with an interface avoiding the rust stdlib. This makes it suitable for embedded devices and kernels. It is design
-
curve25519-dalek A pure-Rust implementation of group operations on ristretto255 and Curve25519
-
criterion-plot Criterion's plotting library
-
num_enum Procedural macros to make inter-operation between primitives and enums easier.
-
num_enum_derive Internal implementation details for ::num_enum (Procedural macros to make inter-operation between primitives and enums easier)
-
tap Generic extensions for tapping values in Rust
-
camino UTF-8 paths
-
radium Portable interfaces for maybe-atomic types
-
cast Ergonomic, checked cast functions for primitive types
-
brotli A brotli compressor and decompressor that with an interface avoiding the rust stdlib. This makes it suitable for embedded devices and kernel
-
combine Fast parser combinators on arbitrary streams with zero-copy support.
-
ref-cast Safely cast &T to &U where the struct U contains a single field of type T.
-
ref-cast-impl Derive implementation for ref_cast::RefCast.
-
pyo3-build-config Build configuration for the PyO3 ecosystem
-
xattr unix extended filesystem attributes
-
funty Trait generalization over the primitive types
-
oorandom A tiny, robust PRNG implementation.
-
libsqlite3-sys Native bindings to the libsqlite3 library
-
fallible-iterator Fallible iterator traits
-
arrayref Macros to take array references of slices
-
aws-lc-sys AWS-LC is a general-purpose cryptographic library maintained by the AWS Cryptography team for AWS and their customers. It іs based on code f
-
pyo3 Bindings to Python interpreter
-
base16ct Pure Rust implementation of Base16 a.k.a hexadecimal (RFC 4648) which avoids any usages of data-dependent branches/LUTs and thereby provides
-
aws-lc-rs aws-lc-rs is a cryptographic library using AWS-LC for its cryptographic operations. This library strives to be API-compatible with the popul
-
png PNG decoding and encoding library in pure Rust
-
pyo3-macros Proc macros for PyO3 package
-
pyo3-macros-backend Code generation for PyO3 package
-
yansi A dead simple ANSI terminal color painting library.
-
web-time Drop-in replacement for std::time for Wasm in browsers
-
adler A simple clean-room implementation of the Adler-32 checksum
-
multimap A multimap implementation.
-
wyz myrrlyn’s utility collection
-
fancy-regex An implementation of regexes, supporting a relatively rich set of features, including backreferences and look-around. Aims to be compatible
-
signal-hook Unix signal handling
-
csv-core Bare bones CSV parsing with no_std support.
-
csv Fast CSV parsing with support for serde.
-
parking Thread parking and unparking
-
serde_derive_internals AST representation used by Serde derive macros. Unstable.
-
schemars_derive Macros for #[derive(JsonSchema)], for use with schemars
-
tonic-build Codegen module of `tonic` gRPC implementation.
-
tinytemplate Simple, lightweight template engine
-
alloc-stdlib A dynamic allocator example that may be used with the stdlib
-
pyo3-ffi Python-API bindings for the PyO3 ecosystem
-
globset Cross platform single glob and glob set matching. Glob set matching is the process of matching one or more glob patterns against a single ca
-
wasmparser A simple event-driven library for parsing WebAssembly binary files.
-
alloc-no-stdlib A dynamic allocator that may be used with or without the stdlib. This allows a package with nostd to allocate memory dynamically and be used
-
sec1 Pure Rust implementation of SEC1: Elliptic Curve Cryptography encoding formats including ASN.1 DER encoded private keys as well as the Ellip
-
ff Library for building and interfacing with finite fields
-
elliptic-curve General purpose Elliptic Curve Cryptography (ECC) support, including traits and generic types for representing various elliptic curve forms,
-
pbkdf2 Generic implementation of PBKDF2
-
tar A Rust implementation of a TAR file reader and writer. This library does not currently handle compression, but it is abstract over all I/O r
-
twox-hash A Rust implementation of the XXHash and XXH3 algorithms
-
ciborium-io Simplified Read/Write traits for no_std usage
-
ciborium serde implementation of CBOR using ciborium-basic
-
ciborium-ll Low-level CBOR codec primitives
-
ecdsa Pure Rust implementation of the Elliptic Curve Digital Signature Algorithm (ECDSA) as specified in FIPS 186-4 (Digital Signature Standard),
-
cookie HTTP cookie parsing and cookie jar management. Supports signed and private (encrypted, authenticated) jars.
-
polling Portable interface to epoll, kqueue, event ports, and IOCP
-
erased-serde Type-erased Serialize and Serializer traits
-
cargo_metadata structured access to the output of `cargo metadata`
-
flume A blazingly fast multi-producer channel
-
simdutf8 SIMD-accelerated UTF-8 validation.
-
toml_writer A low-level interface for writing out TOML
-
ed25519 Edwards Digital Signature Algorithm (EdDSA) over Curve25519 (as specified in RFC 8032) support library providing signature type definitions
-
cargo-platform Cargo's representation of a target platform.
-
urlencoding A Rust library for doing URL percentage encoding.
-
num_threads A minimal library that determines the number of running threads for the current process.
-
opentelemetry_sdk The SDK for the OpenTelemetry metrics collection and distributed tracing framework
-
rfc6979 Pure Rust implementation of RFC6979: Deterministic Usage of the Digital Signature Algorithm (DSA) and Elliptic Curve Digital Signature Algor
-
group Elliptic curve group traits and utilities
-
whoami Rust library for getting information about the current user and environment
-
num-derive Numeric syntax extensions
-
rsa Pure Rust RSA implementation
-
ed25519-dalek Fast and efficient ed25519 EdDSA key generations, signing, and verification in pure Rust.
-
aead Traits for Authenticated Encryption with Associated Data (AEAD) algorithms, such as AES-GCM as ChaCha20Poly1305, which provide a high-level
-
redox_users A Rust library to access Redox users and groups functionality
-
plotters A Rust drawing library focus on data plotting for both WASM and native applications
-
async-compression Adaptors between compression crates and Rust's modern asynchronous IO types.
-
colored The most simple way to add colors in your terminal
-
libz-sys Low-level bindings to the system libz library (also known as zlib).
-
wasip2 WASIp2 API bindings for Rust
-
wait-timeout A crate to wait on a child process with a timeout specified across Unix and Windows platforms.
-
plotters-backend Plotters Backend API
-
plotters-svg Plotters SVG backend
-
anes ANSI Escape Sequences provider & parser
-
async-io Async I/O and timers
-
pkcs1 Pure Rust implementation of Public-Key Cryptography Standards (PKCS) #1: RSA Cryptography Specifications Version 2.2 (RFC 8017)
-
ureq Simple, safe HTTP client
-
predicates An implementation of boolean-valued predicate functions.
-
universal-hash Traits which describe the functionality of universal hash functions (UHFs)
-
rand_pcg Selected PCG random number generators
-
indicatif A progress bar and cli reporting library for Rust
-
winreg Rust bindings to MS Windows Registry API
-
tiny-keccak An implementation of Keccak derived functions.
-
diff An LCS based slice and string diffing implementation.
-
jiff A date-time library that encourages you to jump into the pit of success. This library is heavily inspired by the Temporal project.
-
ctr CTR block modes of operation
-
tracing-opentelemetry OpenTelemetry integration for tracing
-
unindent Remove a column of leading whitespace from a string
-
image Imaging library. Provides basic image processing and encoders/decoders for common image formats.
-
unicode-properties Query character Unicode properties according to UAX #44 and UTR #51.
-
ctor Global, no_std-compatible constructors for all platforms that run before main (like C/C++ __attribute__((constructor)))
-
overload Provides a macro to simplify operator overloading.
-
block-padding Padding and unpadding of messages divided into blocks.
-
ansi_term Library for ANSI terminal colours and styles (bold, underline)
-
sysinfo Library to get system information such as processes, CPUs, disks, components and networks
-
futures-timer Timeouts for futures.
-
env_filter Filter log events using environment variables
-
terminal_size Gets the size of your Linux or Windows terminal
-
jsonwebtoken Create and decode JWTs in a strongly typed way.
-
pretty_assertions Overwrite `assert_eq!` and `assert_ne!` with drop-in replacements, adding colorful diffs.
-
borsh Binary Object Representation Serializer for Hashing
-
similar A diff library for Rust
-
derive_builder Rust macro to automatically implement the builder pattern for arbitrary structs.
-
derive_builder_core Internal helper library for the derive_builder crate.
-
utf-8 Incremental, zero-copy UTF-8 decoding with error handling
-
curve25519-dalek-derive curve25519-dalek Derives
-
jni Rust bindings to the JNI
-
lru-slab Pre-allocated storage with constant-time LRU tracking
-
p256 Pure Rust implementation of the NIST P-256 (a.k.a. secp256r1, prime256v1) elliptic curve as defined in SP 800-186, with support for ECDH, EC
-
predicates-tree Render boolean-valued predicate functions results as a tree.
-
predicates-core An API for boolean-valued predicate functions.
-
hostname Cross-platform system's host name functions
-
regex-lite A lightweight regex engine that optimizes for binary size and compilation time.
-
serde_bytes Optimized handling of `&[u8]` and `Vec<u8>` for Serde
-
crossterm A crossplatform terminal library for manipulating terminals.
-
derive_builder_macro Rust macro to automatically implement the builder pattern for arbitrary structs.
-
jni-sys Rust definitions corresponding to jni.h
-
async-task Task abstraction for building executors
-
encode_unicode UTF-8 and UTF-16 character types, iterators and related methods for char, u8 and u16.
-
lazycell A library providing a lazily filled Cell struct
-
scoped-tls Library implementation of the standard library's old `scoped_thread_local!` macro for providing scoped access to thread local storage (TLS)
-
wasm-encoder A low-level WebAssembly encoder.
-
termtree Visualize tree-like data on the command-line
-
proptest Hypothesis-like property-based testing and shrinking.
-
num-bigint-dig Big integer implementation for Rust
-
blake3 the BLAKE3 hash function
-
io-lifetimes A low-level I/O ownership and borrowing library
-
system-configuration Bindings to SystemConfiguration framework for macOS
-
fdeflate Fast specialized deflate implementation
-
polyval POLYVAL is a GHASH-like universal hash over GF(2^128) useful for constructing a Message Authentication Code (MAC)
-
system-configuration-sys Low level bindings to SystemConfiguration framework for macOS
-
os_str_bytes Lossless functionality for platform-native strings
-
semver-parser Parsing of the semver spec.
-
const-random Provides compile time random number generation.
-
ignore A fast library for efficiently matching ignore files such as `.gitignore` against file paths.
-
rustls-platform-verifier rustls-platform-verifier supports verifying TLS certificates in rustls with the operating system verifier
-
const-random-macro Provides the procedural macro used by const-random
-
toml_write A low-level interface for writing out TOML
-
dirs-sys-next system-level helper functions for the dirs and directories crates
-
simple_asn1 A simple DER/ASN.1 encoding/decoding library.
-
x509-parser Parser for the X.509 v3 format (RFC 5280 certificates)
-
pathdiff Library for diffing paths to obtain relative paths
-
sha3 Implementation of the SHA-3 family of cryptographic hash algorithms
-
yaml-rust The missing YAML 1.2 parser for rust
-
atoi Parse integers directly from `[u8]` slices in safe code
-
raw-cpuid A library to parse the x86 CPUID instruction, written in rust with no external dependencies. The implementation closely resembles the Intel
-
blocking A thread pool for isolating blocking I/O in async programs
-
unarray Utilities for working with uninitialized arrays
-
derivative A set of alternative `derive` attributes for Rust
-
zlib-rs A memory-safe zlib implementation written in rust
-
compact_str A memory efficient string type that transparently stores strings on the stack, when possible
-
aes-gcm Pure Rust implementation of the AES-GCM (Galois/Counter Mode) Authenticated Encryption with Associated Data (AEAD) Cipher with optional arch
-
string_cache A string interning library for Rust, developed as part of the Servo project.
-
protobuf Protocol Buffers - Google's data interchange format
-
der-parser Parser/encoder for ASN.1 BER/DER data
-
blake2 BLAKE2 hash functions
-
opentelemetry-proto Protobuf generated files and transformations.
-
dotenvy A well-maintained fork of the dotenv crate
-
write16 A UTF-16 analog of the Write trait
-
utf16_iter Iterator by char over potentially-invalid UTF-16 in &[u16]
-
secrecy Wrapper types and traits for secret management which help ensure they aren't accidentally copied, logged, or otherwise exposed (as much as p
-
matches A macro to evaluate, as a boolean, whether an expression matches a pattern.
-
iri-string IRI as string types
-
aws-smithy-http Smithy HTTP logic for smithy-rs.
-
asn1-rs Parser/encoder for ASN.1 BER/DER data
-
approx Approximate floating point equality comparisons and assertions.
-
asn1-rs-derive Derive macros for the `asn1-rs` crate
-
ghash Universal hash over GF(2^128) useful for constructing a Message Authentication Code (MAC), as in the AES-GCM authenticated encryption cipher
-
vsimd SIMD utilities
-
wasm-streams Bridging between web streams and Rust streams using WebAssembly
-
hash32 32-bit hashing algorithms
-
bzip2 Bindings to libbzip2 for bzip2 compression and decompression exposed as Reader/Writer streams.
-
inotify Idiomatic wrapper for inotify
-
notify Cross-platform filesystem notification library
-
chrono-tz TimeZone implementations for chrono from the IANA database
-
ptr_meta A radioactive stabilization of the ptr_meta rfc
-
ptr_meta_derive Proc macros for ptr_meta
-
icu_locid_transform_data Data for the icu_locid_transform crate
-
opentelemetry-otlp Exporter for the OpenTelemetry Collector