Rust crates
4,945 in Packages and libraries, most used first. Page 2 of 25.
-
phf Runtime support for perfect hash function data structures
-
windows_i686_gnullvm Import lib for Windows
-
prost-derive Generate encoding and decoding implementations for Prost annotated types.
-
serde_urlencoded `x-www-form-urlencoded` meets Serde
-
pin-project-internal Implementation detail of the `pin-project` crate.
-
pin-project A crate for safe and ergonomic pin-projection.
-
arrayvec A vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString.
-
siphasher SipHash-2-4 and SipHash-1-3 keyed hash functions in pure Rust, with 64-bit and 128-bit output and no_std support
-
unicode-normalization This crate provides functions for normalization of Unicode strings, including Canonical and Compatible Decomposition and Recomposition, as d
-
unicode-segmentation This crate provides Grapheme Cluster, Word and Sentence boundaries according to Unicode Standard Annex #29 rules.
-
rustls-native-certs rustls-native-certs allows rustls to use the platform native certificate store
-
num_cpus Get the number of CPUs on a machine.
-
jobserver An implementation of the GNU Make jobserver for Rust.
-
rustls-pki-types Shared types for the rustls PKI ecosystem
-
sha1 SHA-1 hash function
-
tracing-log Provides compatibility between `tracing` and the `log` crate.
-
rayon Simple work-stealing parallelism for Rust
-
proc-macro-crate Replacement for crate (macro_rules keyword) in proc-macros
-
utf8_iter Iterator by char over potentially-invalid UTF-8 in &[u8]
-
find-msvc-tools Find windows-specific tools, read MSVC versions from the registry and from COM interfaces
-
sharded-slab A lock-free concurrent slab.
-
wasm-bindgen-macro-support Implementation APIs for the `#[wasm_bindgen]` attribute
-
wasm-bindgen-shared Shared support between wasm-bindgen and wasm-bindgen cli, an internal dependency.
-
rayon-core Core APIs for Rayon
-
tower-layer Decorates a `Service` to allow easy composition between `Service`s.
-
gimli A library for reading and writing the DWARF debugging format.
-
nu-ansi-term Library for ANSI terminal colors and styles (bold, underline)
-
wasm-bindgen-macro Definition of the `#[wasm_bindgen]` attribute, an internal dependency
-
rustc-demangle Rust compiler symbol demangling.
-
convert_case Convert strings into any case
-
encoding_rs A Gecko-oriented implementation of the Encoding Standard
-
env_logger A logging implementation for `log` which is configured via an environment variable.
-
libloading Bindings around the platform's dynamic library loading primitives with greatly improved memory safety.
-
hermit-abi Hermit system calls definitions.
-
hyper-util hyper utilities
-
const-oid Const-friendly implementation of the ISO/IEC Object Identifier (OID) standard as defined in ITU X.660, with support for BER/DER encoding/dec
-
minimal-lexical Fast float parsing conversion routines.
-
paste Macros for all your token pasting needs
-
idna_adapter Back end adapter for idna
-
event-listener Notify async tasks or threads
-
js-sys Bindings for all JS global objects and functions in all JS environments like Node.js and browsers, built on `#[wasm_bindgen]` using the `was
-
schemars Generate JSON Schemas from Rust code
-
tower-http Tower middleware and utilities for HTTP clients and servers
-
http-body-util Combinators and adapters for HTTP request or response bodies.
-
zmij A double-to-string conversion algorithm based on Schubfach and xjb
-
rustls-pemfile Basic .pem file parser for keys and certificates
-
prettyplease A minimal `syn` syntax tree pretty-printer
-
powerfmt `powerfmt` is a library that provides utilities for formatting values. This crate makes it significantly easier to support filling to a
-
derive_more Adds #[derive(x)] macros for more traits
-
sync_wrapper A tool for enlisting the compiler's help in proving the absence of concurrency
-
termcolor A simple cross platform library for writing colored text to a terminal.
-
allocator-api2 Mirror of Rust's allocator API
-
petgraph Graph data structure library. Provides graph types and graph algorithms.
-
unicode-bidi Implementation of the Unicode Bidirectional Algorithm
-
vcpkg A library to find native dependencies in a vcpkg tree at build time in order to be used in Cargo build scripts.
-
axum HTTP routing and request handling library that focuses on ergonomics and modularity
-
addr2line A cross-platform symbolication library written in Rust, using `gimli`
-
axum-core Core types and traits for axum
-
tokio-stream Utilities to work with `Stream` and `tokio`.
-
winapi Raw FFI bindings for all of Windows API.
-
libm libm in pure Rust
-
portable-atomic Portable atomic types including support for 128-bit atomics, atomic float, etc.
-
der Pure Rust embedded-friendly implementation of the Distinguished Encoding Rules (DER) for Abstract Syntax Notation One (ASN.1) as described i
-
matchers Regex matching on character and byte streams.
-
fixedbitset FixedBitSet is a simple bitset collection
-
half Half-precision floating point f16 and bf16 types for Rust implementing the IEEE 754-2008 standard binary16 and bfloat16 types.
-
atomic-waker A synchronization primitive for task wakeup
-
adler2 A simple clean-room implementation of the Adler-32 checksum
-
zerotrie A data structure that efficiently maps strings to integers
-
phf_generator PHF generation logic
-
backtrace A library to acquire a stack trace (backtrace) at runtime in a Rust program.
-
windows-link Linking for Windows
-
potential_utf Unvalidated string and character types
-
icu_locale_core API for managing Unicode Language and Locale Identifiers
-
core-foundation Bindings to Core Foundation for macOS
-
prost-types Prost definitions of Protocol Buffers well known types.
-
bit-vec A vector of bits
-
signature Traits for cryptographic signature algorithms (e.g. ECDSA, Ed25519)
-
ordered-float Wrappers for total ordering on floats
-
windows-core Core type support for COM and Windows
-
quick-xml High performance xml reader and writer
-
cfg_aliases A tiny utility to help save you a lot of effort with long winded `#[cfg()]` checks.
-
num-conv `num_conv` is a crate to convert between integer types without using `as` casts. This provides better certainty when refactoring, makes the
-
spki X.509 Subject Public Key Info (RFC5280) describing public keys as well as their associated AlgorithmIdentifiers (i.e. OIDs)
-
openssl-sys FFI bindings to OpenSSL
-
matchit A high performance, zero-copy URL router.
-
foreign-types A framework for Rust wrappers over C APIs
-
foreign-types-shared An internal crate used by foreign-types
-
bstr A string type that is not required to be valid UTF-8.
-
data-encoding Efficient and customizable data-encoding functions like base64, base32, and hex
-
pkcs8 Pure Rust implementation of Public-Key Cryptography Standards (PKCS) #8: Private-Key Information Syntax Specification (RFC 5208), with addit
-
bit-set A set of bits
-
core-foundation-sys Bindings to Core Foundation for macOS
-
base64ct Pure Rust implementation of Base64 (RFC 4648) which avoids any usages of data-dependent branches/LUTs and thereby provides portable "best ef
-
home Shared definitions of home directories.
-
humantime A parser and formatter for std::time::{Duration, SystemTime}
-
simd-adler32 A SIMD-accelerated Adler-32 hash algorithm implementation.
-
winapi-util A dumping ground for high level safe wrappers over windows-sys.
-
zstd-safe Safe low-level bindings for the zstd compression library.
-
unicase A case-insensitive wrapper around strings.
-
which A Rust equivalent of Unix command "which". Locate installed executable in cross platforms.
-
textwrap Library for word wrapping, indenting, and dedenting strings. Has optional support for Unicode and emojis as well as machine hyphenation.
-
winapi-i686-pc-windows-gnu Import libraries for the i686-pc-windows-gnu target. Please don't use this crate directly, depend on winapi instead.
-
zstd Binding for the zstd compression library.
-
tonic A gRPC over HTTP/2 implementation focused on high performance, interoperability, and flexibility.
-
serde_yaml YAML data format for Serde
-
bytemuck A crate for mucking around with piles of bytes.
-
winapi-x86_64-pc-windows-gnu Import libraries for the x86_64-pc-windows-gnu target. Please don't use this crate directly, depend on winapi instead.
-
is_terminal_polyfill Polyfill for `is_terminal` stdlib feature for use with older MSRVs
-
web-sys Bindings for all Web APIs, a procedurally generated crate from WebIDL
-
bindgen Automatically generates Rust FFI bindings to C and C++ libraries.
-
num-rational Rational numbers implementation for Rust
-
num-iter External iterators for generic mathematics
-
filetime Platform-agnostic accessors of timestamps in File metadata
-
quick-error A macro which makes error types pleasant to write.
-
md-5 MD5 hash function
-
cipher Traits for describing block ciphers and stream ciphers
-
windows-result Windows error handling
-
dashmap Blazing fast concurrent HashMap for Rust.
-
static_assertions Compile-time assertions to ensure that invariants are met.
-
security-framework Security.framework bindings for macOS and iOS
-
ident_case Utility for applying case rules to Rust identifiers.
-
crunchy Crunchy unroller: deterministically unroll constant loops
-
serde_with Custom de/serialization functions for Rust's serde
-
lru A LRU cache implementation
-
zstd-sys Low-level bindings for the zstd compression library.
-
dyn-clone Clone trait that is dyn-compatible
-
hashlink HashMap-like containers that hold their key-value pairs in a user controllable order
-
serde_with_macros proc-macro library for serde_with
-
num-complex Complex numbers implementation for Rust
-
target-lexicon LLVM target triple types
-
prost-build Generate Prost annotated Rust types from Protocol Buffers files.
-
crossbeam-queue Concurrent queues
-
quinn-proto State machine for the QUIC transport protocol
-
windows-strings Windows string types
-
console A terminal and console abstraction for Rust
-
toml_parser Yet another format-preserving TOML parser.
-
quinn Versatile QUIC transport protocol implementation
-
wasm-bindgen-futures Bridging the gap between Rust Futures and JavaScript Promises
-
aes Pure Rust implementation of the Advanced Encryption Standard (a.k.a. Rijndael)
-
windows Rust for Windows
-
arc-swap Atomically swappable Arc
-
anstyle-wincon Styling legacy Windows terminals
-
memmap2 Cross-platform Rust API for memory-mapped file IO
-
pem-rfc7468 PEM Encoding (RFC 7468) for PKIX, PKCS, and CMS Structures, implementing a strict subset of the original Privacy-Enhanced Mail encoding inte
-
quinn-udp UDP sockets with ECN information for the QUIC transport protocol
-
dirs-sys System-level helper functions for the dirs and directories crates.
-
hyper-timeout A connect, read and write timeout aware connector to be used with hyper Client.
-
tungstenite Lightweight stream-based WebSocket implementation
-
hyper-tls Default TLS implementation for use with hyper
-
dunce Normalize Windows paths to the most compatible format, avoiding UNC where possible
-
opaque-debug This crate is deprecated. Use explicit impl of `fmt::Debug` instead.
-
pest The Elegant Parser
-
native-tls A wrapper over a platform's native TLS implementation
-
is-terminal Test whether a given stream is a terminal
-
async-stream Asynchronous streams using async & await notation
-
async-stream-impl proc macros for async-stream crate
-
phf_codegen Codegen library for PHF types
-
inout Custom reference types for code generic over in-place and buffer-to-buffer modes of operation.
-
async-channel Async multi-producer multi-consumer channel
-
atty A simple interface for querying atty
-
concurrent-queue Concurrent multi-producer multi-consumer queue
-
bincode A binary serialization / deserialization strategy for transforming structs into bytes and vice versa!
-
proc-macro-error Almost drop-in replacement to panics in proc-macros
-
proc-macro-error-attr Attribute macro for proc-macro-error crate
-
r-efi UEFI Reference Specification Protocol Constants and Definitions
-
windows-implement The implement macro for the Windows crates
-
openssl-macros Internal macros used by the openssl crate.
-
indoc Indented document literals
-
security-framework-sys Apple `Security.framework` low-level FFI bindings
-
windows-interface The interface macro for the Windows crates
-
android_system_properties Minimal Android system properties wrapper
-
ucd-trie A trie for storing Unicode codepoint sets and maps.
-
schannel Schannel bindings for rust, allowing SSL/TLS (e.g. https) without openssl
-
sct Certificate transparency SCT verification library
-
pem Parse and encode PEM-encoded data.
-
instant Unmaintained, consider using web-time instead - A partial replacement for std::time::Instant that works on WASM to.
-
unsafe-libyaml libyaml transpiled to rust by c2rust
-
clang-sys Rust bindings for libclang.
-
iana-time-zone-haiku iana-time-zone support crate for Haiku OS
-
chacha20 The ChaCha20 stream cipher (RFC 8439) implemented in pure Rust using traits from the RustCrypto `cipher` crate, with optional architecture-s
-
fs_extra Expanding std::fs and std::io. Recursively copy folders with information about process and much more.
-
cexpr A C expression parser and evaluator
-
derive_more-impl Internal implementation of `derive_more` crate
-
linked-hash-map A HashMap wrapper that holds key-value pairs in insertion order
-
crc Rust implementation of CRC with support of various standards
-
num A collection of numeric types and traits for Rust, including bigint, complex, rational, range iterators, generic integers, and more!
-
valuable Object-safe value inspection, used to pass un-typed structured data across trait-object boundaries.
-
phf_macros Macros to generate types in the phf crate
-
constant_time_eq Compares two equal-sized byte strings in constant time.
-
mime_guess A simple crate for detection of a file's MIME type by its extension.
-
zip Library to support the reading and writing of zip files.
-
criterion Statistics-driven micro-benchmarking library
-
pest_derive pest's derive macro
-
serde_path_to_error Path to the element that failed to deserialize
-
futures-lite Futures, streams, and async I/O combinators
-
pest_meta pest meta language parser and validator
-
tokio-tungstenite Tokio binding for Tungstenite, the Lightweight stream-based WebSocket implementation
-
hkdf HMAC-based Extract-and-Expand Key Derivation Function (HKDF)
-
async-lock Async synchronization primitives