Rust crates
4,945 in Packages and libraries, most used first. Page 13 of 25.
-
libp2p-yamux Yamux multiplexing protocol for libp2p
-
im-rc Immutable collection datatypes (the fast but not thread safe version)
-
synom Stripped-down Nom parser used by Syn
-
daemonize Library to enable your code run as a daemon process on Unix-like systems.
-
guillotiere A dynamic 2D texture atlas allocator with fast deallocation.
-
gherkin Pure Rust implementation of Gherkin language (`.feature` file) for Cucumber testing framework.
-
soup3 Soup crate for Rust
-
lsp-server Generic LSP server scaffold.
-
isahc The practical HTTP client that is fun to use.
-
tokio-uds Unix Domain sockets for Tokio
-
multihash-derive Proc macro for deriving custom multihash tables.
-
backtrace-sys Bindings to the libbacktrace gcc library
-
alloy-signer-local sepc256k1 ECDSA and YubiHSM signer implementations
-
drain_filter_polyfill current nightly implementation of Vec::drain_filter, copypasted out for use on stable
-
sptr sptr: The Strict Provenance Polyfill
-
tokio-serde Send and receive Serde encodable types over the network using Tokio. This library is used as a building block for serialization format spec
-
asn1_derive #[derive] support for asn1
-
substrait Cross-Language Serialization for Relational Algebra
-
wild Glob (wildcard) expanded command-line arguments on Windows
-
asn1 ASN.1 (DER) parser and writer for Rust.
-
notify-debouncer-mini notify mini debouncer for events
-
polars-utils Private utils for the Polars DataFrame library
-
crossbeam-skiplist A concurrent skip list
-
memory-stats A cross-platform memory profiler for Rust.
-
frame-metadata Metadata types for Substrate runtimes
-
ffi_helpers A crate to help make working with FFI easier.
-
sentry-anyhow Sentry integration for anyhow.
-
dasp_sample An abstraction for audio PCM DSP samples, along with useful conversions and operations.
-
sfv Structured Field Values for HTTP parser. Implementation of RFC 8941 and RFC 9651.
-
libp2p-swarm-derive Procedural macros of libp2p-swarm
-
argh_shared Derive-based argument parsing optimized for code size
-
alloy-rpc-client Low-level Ethereum JSON-RPC client implementation
-
solana-hash Solana wrapper for the 32-byte output of a hashing algorithm.
-
tame-index Provides access to local and remote cargo registry indices
-
rusttype A pure Rust alternative to libraries like FreeType. RustType provides an API for loading, querying and rasterising TrueType fonts. It also
-
alloy-chains Canonical type definitions for EIP-155 chains
-
parity-wasm WebAssembly low-level format library
-
bytes-str A string type that is backed by bytes crate
-
unsafe-any-ors Traits and implementations for unchecked downcasting.
-
wasmtime-jit-icache-coherence Utilities for JIT icache maintenance
-
sled Lightweight high-performance pure-rust transactional embedded database.
-
cucumber Cucumber testing framework for Rust, with async support. Fully native, no external test runners or dependencies.
-
subtle-ng Pure-Rust traits and utilities for constant-time cryptographic implementations.
-
wasmtime-asm-macros Macros for defining asm functions in Wasmtime
-
svg_fmt Very simple debugging utilities to dump shapes in SVG format.
-
alloy-transport-http HTTP transport implementation
-
alloy-provider Interface with an Ethereum blockchain
-
atomic_float Floating point types which can be safely shared between threads
-
cucumber-codegen Code generation for `cucumber` crate.
-
tokio-udp UDP bindings for tokio.
-
swash Font introspection, complex text shaping and glyph rendering.
-
ethabi Easy to use conversion of ethereum contract calls to bytecode.
-
alloy-transport Low-level Ethereum JSON-RPC transport abstraction
-
cgl Rust bindings for CGL on Mac
-
typemap-ors A typesafe store for many value types.
-
polars-arrow Minimal implementation of the Arrow specification forked from arrow2
-
unicode-security Detect possible security problems with Unicode usage according to Unicode Technical Standard #39 rules.
-
tokio-fs Filesystem API for Tokio.
-
argh Derive-based argument parsing optimized for code size
-
curve25519-dalek-ng A pure-Rust implementation of group operations on ristretto255 and Curve25519
-
notify-rust Show desktop notifications (linux, bsd, mac). Pure Rust dbus client and server.
-
epaint_default_fonts Default fonts for use in epaint / egui
-
argh_derive Derive-based argument parsing optimized for code size
-
polars-core Core of the Polars DataFrame library
-
linux-keyutils Rust interface to the Linux key-management facility. Provides a safe interface around the raw system calls allowing user-space programs to p
-
yeslogic-fontconfig-sys Raw bindings to Fontconfig without a vendored C library
-
nonmax Numeric types that cannot hold maximum values
-
libp2p-identify Nodes identification protocol for libp2p
-
discard Discard trait which allows for intentionally leaking memory
-
vswhom FFI to Jon Blow's VS discovery script
-
polars-error Error definitions for the Polars DataFrame library
-
macro_magic_core_macros Support macros for macro_magic_core
-
murmurhash32 A simple implementation of murmurhash32_2
-
android-properties Rust-based Android properties wrapper
-
datafusion-macros Procedural macros for DataFusion query engine
-
macro_magic_macros Proc-macro sub-crate for macro_magic
-
macro_magic_core Core implementation behind macro_magic
-
macro_magic Allows the exporting and importing of the tokens of items across module, file, and crate boundaries
-
destructure_traitobject Unsafe helpers for working with raw trait objects. (Forked from traitobject)
-
async-tungstenite Async binding for Tungstenite, the Lightweight stream-based WebSocket implementation
-
fixed_decimal An API for representing numbers in a human-readable form
-
toml-span Toml parser and deserializer that preserves span information
-
atspi Pure-Rust, zbus-based AT-SPI2 protocol implementation.
-
datafusion-functions-table Traits and types for logical plans and expressions for DataFusion query engine
-
libudev-sys FFI bindings to libudev
-
canonical-path Path and PathBuf-like types for representing canonical filesystem paths
-
datafusion-doc Documentation module for DataFusion query engine
-
calamine An Excel/OpenDocument Spreadsheet reader and deserializer in pure Rust
-
vswhom-sys Pure FFI to Jon Blow's VS discovery script
-
bnum Fixed-size integer types with generic signedness, bit width and overflow behaviour.
-
chardetng A character encoding detector for legacy Web content
-
cucumber-expressions Cucumber Expressions AST and parser.
-
debug-ignore A newtype wrapper that causes a field to be skipped while printing out Debug output.
-
content_inspector Fast inspection of binary buffers to guess/determine the encoding
-
interprocess Interprocess communication toolkit
-
google-cloud-gax-internal Google Cloud Client Libraries for Rust - Implementation Details
-
diffy Tools for finding and manipulating differences between files
-
link-section Link-time initialized slices for Rust, with full support for Linux, macOS, Windows, WASM and many more platforms.
-
temp-env Set environment variables temporarily.
-
hash-db Trait for hash-keyed databases.
-
ssh-encoding Pure Rust implementation of SSH data type decoders/encoders as described in RFC4251
-
c-kzg A minimal implementation of the Polynomial Commitments API for EIP-4844 and EIP-7594, written in C.
-
polars-io IO related logic for the Polars DataFrame library
-
pythonize Serde Serializer & Deserializer from Rust <--> Python, backed by PyO3.
-
axum-test Easy E2E testing for Axum
-
mio-extras Extra components for use with Mio
-
cranelift-wasm Translator from WebAssembly to Cranelift IR
-
objc2-contacts Bindings to the Contacts framework
-
schnorrkel Schnorr VRF, signatures, etc. using the Ristretto group
-
bip32 BIP32 hierarchical key derivation implemented in a generic, no_std-friendly manner. Supports deriving keys using the pure Rust k256 crate or
-
clap_complete_nushell A generator library used with clap for Nushell completion scripts
-
fluent An umbrella crate exposing the combined features of fluent-rs crates with additional convenience macros for Project Fluent, a localization s
-
argminmax ArgMinMax (argmin & argmax in 1 function) with SIMD for floats and integers
-
float_eq Compare IEEE floating point primitives, structs and collections for equality.
-
output_vt100 Utility to activate escape codes in Windows' CMD and PowerShell
-
get-size Determine the size in bytes an object occupies inside RAM.
-
now a time toolkit for chrono
-
alloy-tx-macros Derive macro for transaction envelopes
-
coreaudio-rs A friendly rust interface for Apple's CoreAudio API.
-
stdweb-internal-macros Internal procedural macros for the `stdweb` crate
-
tree-sitter-javascript JavaScript grammar for tree-sitter
-
polars-lazy Lazy query engine for the Polars DataFrame library
-
stdweb-derive Derive macros for the `stdweb` crate
-
polars-ops More operations on Polars data structures
-
async-mutex Async mutex
-
ssh-cipher Pure Rust implementation of SSH symmetric encryption including support for the modern aes128-gcm@openssh.com/aes256-gcm@openssh.com and chac
-
stdweb-internal-runtime Internal runtime for the `stdweb` crate
-
varint-rs A small, zero dependency varint implementation in Rust.
-
objc2-symbols Bindings to the Symbols framework
-
objc2-link-presentation Bindings to the LinkPresentation framework
-
secret-service Library to interface with Secret Service API
-
polars-row Row encodings for the Polars DataFrame library
-
protoc-gen-tonic Protocol Buffers compiler plugin for gRPC services powered by Prost! and Tonic
-
divan-macros Macros for Divan, a statistically-comfy benchmarking library.
-
libp2p-metrics Metrics for libp2p
-
polars-time Time related code for the Polars DataFrame library
-
egui-wgpu Bindings for using egui natively using the wgpu library
-
trim-in-place In-place trimming strings.
-
protox A rust implementation of the protobuf compiler.
-
lab Tools for converting RGB colors to the CIE-L*a*b* color space, and comparing differences in color.
-
block-sys Raw bindings to Apple's C language extension of blocks
-
polars-plan Lazy query engine for the Polars DataFrame library
-
witx Parse and validate witx file format
-
failsafe A circuit breaker implementation
-
kamadak-exif Exif parsing library written in pure Rust
-
get-size-derive Derives the GetSize trait.
-
binrw A Rust crate for helping read structs from binary data using ✨macro magic✨
-
sendfd Send file descriptors along with data over UNIX domain sockets
-
binrw_derive Derive macro for binrw
-
pep440_rs A library for python version numbers and specifiers, implementing PEP 440
-
icu_decimal API for formatting basic decimal numbers in a locale-sensitive way
-
protox-parse Parsing of protobuf source files
-
serde_html_form (De-)serialization support for the `application/x-www-form-urlencoded` format
-
ed25519-dalek-bip32 Simplified ed25519 BIP32 derivations
-
internment Easy interning of data
-
atspi-common Primitive types used for sending and receiving Linux accessibility events.
-
atspi-proxies AT-SPI2 proxies to query or manipulate UI objects
-
jsonschema-regex ECMA 262 regex translation for the jsonschema crate
-
icu_decimal_data Data for the icu_decimal crate
-
quad-rand Pseudo random implementation with core atomics.
-
rustfix Automatically apply the suggestions made by rustc
-
cap-time-ext Extension traits for `SystemClock` and `MonotonicClock`
-
turmoil Simulation testing framework for distributed systems
-
deno_core_icudata Raw ICU data for use with deno_core
-
zeno High performance, low level 2D path rasterization.
-
rc2 RC2 block cipher
-
openidconnect OpenID Connect library
-
igd-next Internet Gateway Protocol client
-
yazi DEFLATE/zlib compression and decompression.
-
pcap-file A crate to parse, read and write Pcap and PcapNg
-
deltae Calculate Delta E between two colors in CIE Lab space.
-
skeptic Test your Rust markdown documentation via Cargo
-
unic-emoji-char UNIC — Unicode Emoji — Emoji Character Properties
-
alloy-core Rust Ethereum core libraries
-
datafusion-catalog-listing datafusion-catalog-listing
-
cms Pure Rust implementation of the Cryptographic Message Syntax (CMS) as described in RFC 5652 and RFC 3274.
-
opentelemetry-prometheus Prometheus exporter for OpenTelemetry
-
sluice Efficient ring buffer for byte buffers, FIFO queues, and SPSC channels
-
c2-chacha The ChaCha family of stream ciphers
-
diesel-async An async extension for Diesel the safe, extensible ORM and Query Builder
-
fast-srgb8 Very fast conversions between linear float and 8-bit sRGB (with no_std support).
-
accesskit_unix AccessKit UI accessibility infrastructure: Linux adapter
-
mur3 The rust language implementation of MurmurHash3.
-
datafusion-datasource datafusion-datasource
-
treeline a library for visualizing tree structured data
-
gcd Calculate the greatest common divisor
-
cow-utils Copy-on-write string utilities for Rust
-
objc2-uniform-type-identifiers Bindings to the UniformTypeIdentifiers framework
-
capnp runtime library for Cap'n Proto data encoding
-
trait-variant Utilities for working with impl traits in Rust
-
synthez-codegen Internal codegen shim of `synthez` crate.
-
tree-sitter-go Go grammar for tree-sitter
-
jemalloc-ctl A safe wrapper over jemalloc's control and introspection APIs
-
synthez-core Internal implementations of `synthez` crate.
-
libp2p-kad Kademlia protocol for libp2p
-
solana-define-syscall Solana define_syscall macro and core syscall definitions.
-
uniffi_bindgen a multi-language bindings generator for rust (codegen and cli tooling)
-
libp2p-ping Ping protocol for libp2p
-
solana-sdk Solana SDK
-
metrics-exporter-statsd metrics-rs exporter that supports reporting metrics to StatsD