Python packages
9,553 in Packages and libraries, most used first. Page 2 of 48.
-
uritemplate Implementation of RFC 6570 URI Templates
-
sentry-sdk Python client for Sentry (https://sentry.io)
-
blinker Fast, simple object-to-object and broadcast signaling
-
librt Mypyc runtime library
-
sympy Computer algebra system (CAS) in Python
-
pypdf A pure-python PDF library capable of splitting, merging, cropping, and transforming PDF files
-
jsonpointer Identify specific nodes in a JSON document (RFC 6901)
-
google-api-python-client Google API Client Library for Python
-
mpmath Python library for arbitrary-precision floating-point arithmetic
-
ptyprocess Run a subprocess in a pseudo terminal
-
google-auth-httplib2 Google Authentication Library: httplib2 transport
-
pexpect Pexpect allows easy control of interactive console applications.
-
aiofiles File support for asyncio.
-
asgiref ASGI specs, helper code, and adapters
-
async-timeout Timeout context manager for asyncio programs
-
traitlets Traitlets Python configuration system
-
httplib2 A comprehensive HTTP client library.
-
webencodings Character encoding aliases for legacy web content
-
azure-identity Microsoft Azure Identity Library for Python
-
rapidfuzz rapid fuzzy string matching
-
pytest-json-ctrf Pytest plugin to generate json report in CTRF (Common Test Report Format)
-
narwhals Extremely lightweight compatibility layer between dataframe libraries
-
black The uncompromising code formatter.
-
google-auth-oauthlib Google Authentication Library
-
msal-extensions Microsoft Authentication Library extensions (MSAL EX) provides a persistence API that can save your data on disk, encrypted on Windows, macO
-
opentelemetry-util-http Web util for OpenTelemetry
-
opentelemetry-exporter-otlp-proto-grpc OpenTelemetry Collector Protobuf over gRPC Exporter
-
authlib The ultimate Python library in building OAuth and OpenID Connect servers and clients.
-
asyncpg An asyncio PostgreSQL driver
-
sqlparse A non-validating SQL parser.
-
fastjsonschema Fastest Python implementation of JSON schema
-
multiprocess better multiprocessing and multithreading in Python
-
jsonpatch Apply JSON-Patches (RFC 6902)
-
paramiko SSH2 protocol library
-
executing Get the currently executing AST node of a frame, and other information
-
snowflake-connector-python Snowflake DB driver for Python
-
joserfc The ultimate Python library for JOSE RFCs, including JWS, JWE, JWK, JWA, JWT
-
grpc-google-iam-v1 IAM API client library
-
tornado Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed.
-
ipython IPython: Productive Interactive Computing
-
llama-parse Parse files into RAG-Optimized formats.
-
transformers Transformers: the model-definition framework for state-of-the-art machine learning models in text, vision, audio, and multimodal models, for
-
parso A Python Parser
-
jedi An autocompletion tool for Python that can be used for text editors.
-
python-docx Create, read, and update Microsoft Word .docx files.
-
xlsxwriter A Python module for creating Excel XLSX files.
-
azure-storage-blob Microsoft Azure Blob Storage Client Library for Python
-
typedload Load and dump data from json-like format into typed data structures
-
pyproject-hooks Wrappers to call pyproject.toml-based build backend hooks.
-
structlog Structured Logging for Python
-
asttokens Annotate AST trees with source code positions
-
xmltodict Makes working with XML feel like you are working with JSON
-
fastuuid Python bindings to Rust's UUID library.
-
litellm Library to easily interface with LLM API providers
-
pyee A rough port of Node.js's EventEmitter to Python with a few tricks of its own
-
matplotlib-inline Inline Matplotlib backend for Jupyter
-
pure-eval Safely evaluate AST nodes without side effects
-
markdown Python implementation of John Gruber's Markdown.
-
tinycss2 A tiny CSS parser
-
isort A Python utility / library to sort Python imports.
-
pyzmq Python bindings for 0MQ
-
build A simple, correct Python build frontend
-
google-cloud-aiplatform Vertex AI API client library
-
stack-data Extract data from python stack frames and tracebacks for informative displays
-
aioitertools itertools and builtins for AsyncIO and mixed iterables
-
python-json-logger JSON Log Formatter for the Python Logging Package
-
watchdog Filesystem events monitoring
-
poetry-core Poetry PEP 517 Build Backend
-
pytest-timeout pytest plugin to abort hanging tests
-
awswrangler Pandas on AWS.
-
marshmallow A lightweight library for converting complex datatypes to and from native Python datatypes.
-
pymupdf A high performance Python library for data extraction, analysis, conversion & manipulation of PDF (and other) documents.
-
pytest-mock Thin-wrapper around the mock package for easier use with pytest
-
brotli Python bindings for the Brotli compression library
-
cachecontrol httplib2 caching for requests
-
databricks-sdk Databricks SDK for Python (Beta)
-
nest-asyncio Patch asyncio to allow nested event loops
-
ast-serialize Python bindings for mypy AST serialization
-
debugpy An implementation of the Debug Adapter Protocol for Python
-
flatbuffers The FlatBuffers serialization format for Python
-
setuptools-scm the blessed package to manage your versions by scm tags
-
langsmith Client library to connect to the LangSmith Observability and Evaluation Platform.
-
jupyter-core Jupyter core package. A base package on which Jupyter projects rely.
-
cython The Cython compiler for writing C extensions in the Python language.
-
nbformat The Jupyter Notebook format
-
croniter croniter provides iteration for datetime object with cron like format
-
lz4 LZ4 Bindings for Python
-
pymysql Pure Python MySQL Driver
-
slack-sdk The Slack API Platform SDK for Python
-
safetensors
-
pytokens A Fast, spec compliant Python 3.14+ tokenizer that runs on older Pythons.
-
rich-toolkit Rich toolkit for building command-line applications
-
sqlglot An easily customizable SQL parser and transpiler
-
onnxruntime ONNX Runtime is a runtime accelerator for Machine Learning models
-
jupyter-client Jupyter protocol implementation and client libraries
-
vcs-versioning the blessed package to manage your versions by vcs metadata
-
pyperclip A cross-platform clipboard module for Python. (Only handles plain text for now.)
-
beartype Unbearably fast near-real-time pure-Python runtime-static type-checker.
-
jsonref jsonref is a library for automatic dereferencing of JSON Reference objects for Python.
-
uuid-utils Fast, drop-in replacement for Python's uuid module, powered by Rust.
-
cyclopts Intuitive, easy CLIs based on type hints.
-
termcolor ANSI color formatting for output in terminal
-
pycryptodome Cryptographic library for Python
-
opentelemetry-instrumentation-fastapi OpenTelemetry FastAPI Instrumentation
-
tomli-w A lil' TOML writer
-
mccabe McCabe checker, plugin for flake8
-
mdit-py-plugins Collection of plugins for markdown-it-py
-
cbor2 CBOR (de)serializer with extensive tag support
-
xlrd Library for developers to extract data from Microsoft Excel (tm) .xls spreadsheet files
-
opentelemetry-instrumentation-requests OpenTelemetry requests instrumentation
-
datasets HuggingFace community-driven open-source library of datasets
-
py4j Enables Python programs to dynamically access arbitrary Java objects
-
opentelemetry-instrumentation-asgi ASGI instrumentation for OpenTelemetry
-
reportlab The Reportlab Toolkit
-
pathable Object-oriented paths
-
loguru Python logging made (stupidly) simple
-
jsonschema-path JSONSchema Spec with object-oriented paths
-
lark a modern parsing library
-
linkify-it-py Links recognition library with FULL unicode support.
-
text-unidecode The most basic Text::Unidecode port
-
semver Python helper for Semantic Versioning (https://semver.org)
-
faker Faker is a Python package that generates fake data for you.
-
pymongo PyMongo - the Official MongoDB Python driver
-
importlib-resources Read resources from Python packages
-
python-slugify A Python slugify application that also handles Unicode
-
py-key-value-aio Async Key-Value Store - A pluggable interface for KV Stores
-
psycopg2 psycopg2 - Python-PostgreSQL Database Adapter
-
griffelib Signatures for entire Python programs. Extract the structure, the frame, the skeleton of your project, to generate API documentation or find
-
rich-rst A beautiful reStructuredText renderer for rich
-
typing-inspect Runtime inspection utilities for typing module.
-
pypdfium2 Python bindings to PDFium
-
argon2-cffi-bindings Low-level CFFI bindings for Argon2
-
wsproto Pure-Python WebSocket protocol implementation
-
deprecation A library to handle automated deprecations
-
aiosqlite asyncio bridge to the standard sqlite3 module
-
mistune A sane and fast Markdown parser with useful plugins and renderers
-
requests-file File transport adapter for Requests
-
bleach An easy safelist-based HTML-sanitizing tool.
-
ruamel.yaml.clib C version of reader, parser and emitter for ruamel.yaml derived from libyaml
-
argon2-cffi Argon2 for Python
-
scramp An implementation of the SCRAM protocol.
-
python-pptx Create, read, and update PowerPoint 2007+ (.pptx) files.
-
invoke Pythonic task execution
-
graphql-core GraphQL-core is a Python port of GraphQL.js, the JavaScript reference implementation for GraphQL.
-
rfc3339-validator A pure python RFC3339 validator
-
shapely Manipulation and analysis of geometric objects
-
torch Tensors and Dynamic neural networks in Python with strong GPU acceleration
-
opentelemetry-exporter-otlp OpenTelemetry Collector Exporters
-
smart-open Utils for streaming large files (S3, HDFS, GCS, SFTP, Azure Blob Storage, gzip, bz2, zst...)
-
pycodestyle Python style guide checker
-
caio Asynchronous file IO for Linux MacOS or Windows.
-
llama-cloud-services Tailored SDK clients for LlamaCloud services.
-
mmh3 Python extension for MurmurHash (MurmurHash3), a set of fast and robust hash functions.
-
argcomplete Bash tab completion for argparse
-
toolz List processing tools and functional utilities
-
google-cloud-secret-manager Google Cloud Secret Manager API client library
-
comm Jupyter Python Comm implementation, for usage in ipykernel, xeus-python etc.
-
textual Modern Text User Interface framework
-
uncalled-for Async dependency injection for Python functions
-
jsonpath-ng A final implementation of JSONPath for Python that aims to be standard compliant, including arithmetic and binary comparison operators and p
-
ipython-pygments-lexers Defines a variety of Pygments lexers for highlighting IPython code.
-
markdownify Convert HTML to markdown.
-
ipykernel IPython Kernel for Jupyter
-
aiofile Asynchronous file operations.
-
grpclib Pure-Python gRPC implementation for asyncio
-
durationpy Module for converting between datetime.timedelta and Go's Duration strings.
-
fastmcp The fast, Pythonic way to build MCP servers and clients.
-
pdfminer.six PDF parser and analyzer
-
deepdiff Deep Difference and Search of any Python object/data. Recreate objects by adding adding deltas to each other.
-
hypothesis The property-based testing library for Python
-
pendulum Python datetimes made easy
-
responses A utility library for mocking out the `requests` Python library.
-
openapi-pydantic Modern, type-safe OpenAPI schemas in Python using Pydantic 1.8+ and 2.x
-
numba compiling Python code using LLVM
-
llvmlite lightweight wrapper around basic LLVM functionality
-
pydantic-extra-types Extra Pydantic types.
-
synchronicity Export blocking and async library versions from a single async implementation
-
requests-aws4auth AWS4 authentication for Requests
-
langchain-protocol Python bindings for the LangChain agent streaming protocol
-
nbclient A client library for executing notebooks. Formerly nbconvert's ExecutePreprocessor.
-
typeguard Run-time type checker for Python
-
nbconvert Convert Jupyter Notebooks (.ipynb files) to other formats.
-
click-repl REPL plugin for Click
-
installer A library for installing Python wheels.
-
msrest AutoRest swagger generator Python client runtime.
-
backports.zstd Backport of compression.zstd
-
zope.interface Interfaces for Python
-
plotly An open-source interactive data visualization library for Python
-
pygithub Use the full Github API v3
-
dulwich Python Git Library
-
pandocfilters Utilities for writing pandoc filters in python
-
nvidia-nccl-cu12 NVIDIA Collective Communication Library (NCCL) Runtime
-
jupyterlab-pygments Pygments theme using JupyterLab CSS variables
-
antlr4-python3-runtime ANTLR 4.13.2 runtime for Python 3
-
fastmcp-slim The dependency-slim FastMCP package.
-
pyspark Apache Spark Python API
-
tree-sitter Python bindings to the Tree-sitter parsing library
-
opentelemetry-instrumentation-httpx OpenTelemetry HTTPX Instrumentation
-
pyflakes passive checker of Python programs
-
pycryptodomex Cryptographic library for Python