npm packages
9,484 in Packages and libraries, most used first. Page 14 of 48.
-
svg-parser Create a JSON-friendly object from an SVG string
-
quickselect A tiny and fast selection algorithm in JavaScript.
-
@tanstack/router-generator Modern and scalable routing for React applications
-
@ai-sdk/openai The OpenAI provider for the AI SDK contains…
-
is-retry-allowed Check whether a request can be retried based on the error.code
-
postcss-safe-parser Fault-tolerant CSS parser for PostCSS
-
dset A tiny (194B) utility for safely writing deep Object values~!
-
@graphql-codegen/plugin-helpers GraphQL Code Generator common utils and types
-
for-in Iterate over the own and inherited enumerable properties of an object, and return an object with properties that evaluate to true from the…
-
get-own-enumerable-property-symbols Returns an array of all enumerable symbol properties found directly upon a given object
-
@expo/config A library for interacting with the app.json
-
base64id Generates a base64 id
-
@react-native/babel-plugin-codegen Babel plugin to generate native module and view manager code for React Native.
-
npm-bundled list things in node_modules that are bundledDependencies, or transitive dependencies thereof
-
react-devtools-core Use react-devtools outside of the browser
-
unist-util-find-after unist utility to find a node after another node
-
socket.io-client Realtime application framework client
-
unbash The best bash parser in JavaScript. Fast, complete, typed.
-
parse-passwd Parse a passwd file into a list of users.
-
stackback return list of CallSite objects from a captured stacktrace
-
has-unicode Try to guess if your terminal supports unicode
-
wide-align A wide-character aware text alignment function for use on the console or with fixed width fonts.
-
helmet help secure Express/Connect apps with various HTTP headers
-
lru.min 🔥 An extremely fast and efficient LRU cache for JavaScript with high compatibility (including Browsers).
-
@npmcli/promise-spawn spawn processes the way the npm cli likes to do
-
@dotenvx/dotenvx A secure dotenv–from the creator of dotenv
-
hast-util-to-text hast utility to get the plain-text value of a node according to the innerText algorithm
-
mini-css-extract-plugin extracts CSS into separate files
-
@codemirror/view DOM view component for the CodeMirror code editor
-
ansi-html-community An elegant lib that converts the chalked (ANSI) text to HTML. (Community)
-
yaml-ast-parser
-
@tanstack/router-plugin Modern and scalable routing for React applications
-
@sentry/babel-plugin-component-annotate A Babel plugin that annotates frontend components with additional data to enrich the experience in Sentry
-
@aws-sdk/middleware-eventstream
-
iterare Array methods for ES6 Iterators
-
npm-install-checks Check the engines and platform fields in package.json
-
hast-util-from-html hast utility to parse from HTML
-
@aws-sdk/client-bedrock-runtime AWS SDK for JavaScript Bedrock Runtime Client for Node.js, Browser and React Native
-
@peculiar/asn1-pkcs8 ASN.1 schema for PKCS #8 private key information structures defined in RFC 5208.
-
@redis/client The source code and documentation for this package are in the main node-redis repo.
-
@upsetjs/venn.js Area Proportional Venn and Euler Diagrams
-
sass-loader Sass loader for webpack
-
micromark-factory-mdx-expression micromark factory to parse MDX expressions (found in JSX attributes, flow, text)
-
set-value Create nested values and any intermediaries using dot notation ('a.b.c') paths.
-
@peculiar/asn1-ecc ASN.1 schema for elliptic-curve private keys and related identifiers defined in RFC 5915, RFC 5480, and RFC 3279.
-
lru-memoizer Memoize functions results using an lru-cache.
-
classcat Build a class attribute string quickly.
-
tsyringe Lightweight dependency injection container for JavaScript/TypeScript
-
camelize recursively transform key strings to camel-case
-
create-hash create hashes for browserify
-
iron-webcrypto A cryptographic utility for sealing-unsealing a JSON object using symmetric key encryption with message integrity verification
-
@scarf/scarf Scarf is like Google Analytics for your npm packages. Gain insights into how your packages are installed and used, and by which companies.
-
@sentry/types Types for all Sentry JavaScript SDKs
-
micromark-extension-mdx-jsx micromark extension to support MDX or MDX.js JSX
-
@kwsites/file-exists Synchronous validation of a path existing either as a file or as a directory.
-
@peculiar/asn1-cms ASN.1 schema for Cryptographic Message Syntax (CMS) defined in RFC 5652.
-
@tweenjs/tween.js Simple and fast tweening engine with optimised Robert Penner's equations.
-
uid A tiny (130B to 205B) and fast utility to randomize unique IDs of fixed length
-
xmlhttprequest-ssl XMLHttpRequest for Node
-
@volar/source-map Maps positions and ranges between virtual (generated) and original (source) text, in the span map model of TypeScript 7.1…
-
@fastify/ajv-compiler Build and manage the AJV instances for the fastify framework
-
connect-history-api-fallback Provides a fallback for non-existing directories so that the HTML 5 history API can be used.
-
getenv Get and typecast environment variables.
-
@expo/config-types Types for the Expo config object app.config.ts
-
@peculiar/asn1-csr ASN.1 schema for PKCS #10 certificate signing requests defined in RFC 2986.
-
npm-packlist Get a list of the files to add from a folder into an npm package
-
auto-bind Automatically bind methods to their class instance
-
@peculiar/asn1-pkcs9 ASN.1 schema for PKCS #9 selected attribute types defined in RFC 2985.
-
webpack-dev-server Serves a webpack app. Updates the browser on changes.
-
@peculiar/asn1-pfx ASN.1 schema for PKCS #12 personal information exchange structures defined in RFC 7292.
-
shimmer Safe(r) monkeypatching for JavaScript.
-
abstract-logging A noop logger that conforms to the Log4j interface for modules to stub out internal logging
-
@jsdevtools/ono Throw better errors.
-
jspdf PDF Document creation from JavaScript
-
jpeg-js A pure javascript JPEG encoder and decoder
-
meshoptimizer Mesh optimization library that makes meshes smaller and faster to render
-
@fastify/error A small utility, used by Fastify itself, for generating consistent error objects across your codebase and plugins.
-
react-error-boundary Simple reusable React error boundary component
-
@peculiar/asn1-x509-attr ASN.1 schema for X.509 attribute certificates defined in RFC 5755.
-
vlq Generate, and decode, base64 VLQ mappings for source maps and other uses
-
json-schema-ref-resolver JSON schema reference resolver
-
@volar/language-core
-
aws-ssl-profiles AWS RDS SSL certificates bundles.
-
svg-pathdata Manipulate SVG path data (path[d] attribute content) simply and efficiently.
-
@react-types/shared Spectrum UI components in React
-
async-lock Lock on asynchronous code
-
@sentry/bundler-plugin-core Sentry Bundler Plugin Core
-
console-control-strings A library of cross-platform tested terminal/console command strings for doing things like color and cursor positioning.
-
@mui/utils Utility functions for React components.
-
cssnano-utils Utility methods and plugin for cssnano projects
-
@aws-sdk/middleware-websocket
-
filesize Lightweight, zero-dependency JavaScript utility to convert bytes to human-readable strings with localization support
-
@fastify/fast-json-stringify-compiler Build and manage the fast-json-stringify instances for the fastify framework
-
@actions/core Actions core lib
-
avvio Asynchronous bootstrapping of Node applications
-
lightningcss-linux-arm64-gnu A CSS parser, transformer, and minifier written in Rust
-
@ai-sdk/anthropic The Anthropic provider for the AI SDK contains…
-
@axe-core/playwright Provides a method to inject and analyze web pages using axe
-
@whatwg-node/fetch Cross Platform Smart Fetch Ponyfill
-
@esbuild/win32-x64 The Windows 64-bit binary for esbuild, a JavaScript bundler.
-
has Object.prototype.hasOwnProperty.call shortcut
-
@react-native/gradle-plugin Gradle Plugin for React Native
-
@peculiar/x509 @peculiar/x509 is an easy to use TypeScript/Javascript library based on @peculiar/asn1-schema that makes generating X.509 Certificates and…
-
@fastify/merge-json-schemas Builds a logical conjunction (AND) of multiple JSON schemas
-
lodash.snakecase The lodash method _.snakeCase exported as a module.
-
serve-index Serve directory listings
-
canvg JavaScript SVG parser and renderer on Canvas.
-
@vue/devtools-api Public plugin API for Vue DevTools
-
estree-util-visit esast (and estree) utility to visit nodes
-
@oxfmt/binding-linux-x64-gnu Formatter for the JavaScript Oxidation Compiler
-
rgbcolor A module to parse color values
-
resize-observer-polyfill A polyfill for the Resize Observer API
-
unist-util-position-from-estree unist utility to get a position from an estree node
-
@react-native/virtualized-lists Virtualized lists for React Native.
-
bcryptjs Optimized bcrypt in plain JavaScript with zero dependencies, with TypeScript support. Compatible to 'bcrypt'.
-
buffer-image-size get dimensions of any image buffer
-
spdy Implementation of the SPDY protocol on node.js.
-
hyperdyperid Fastest random ID and random string generation for Node.js
-
dataloader A data loading utility to reduce requests to a backend via batching and caching.
-
select-hose Select protocol using first bytes of incoming data and hose stuff to the handler
-
@actions/io Actions io lib
-
matcher Simple wildcard matching
-
fuse.js Lightweight fuzzy-search
-
arch Better os.arch() for node and the browser -- detect OS architecture
-
@leichtgewicht/ip-codec Small package to encode or decode IP addresses from buffers to strings.
-
@oozcitak/url An implementation of the URL Living Standard
-
micromark-util-events-to-acorn micromark utility to try and parse events w/ acorn
-
css-declaration-sorter Sorts CSS declarations fast and automatically in a certain order.
-
@smithy/chunked-blob-reader
-
@aws-sdk/util-format-url
-
@smithy/chunked-blob-reader-native
-
global-agent Global HTTP/HTTPS proxy configurable using environment variables.
-
@xyflow/system xyflow core system that powers React Flow and Svelte Flow.
-
@react-native/community-cli-plugin Core CLI commands for React Native
-
p-defer Create a deferred promise
-
hast-util-sanitize hast utility to sanitize nodes
-
@actions/exec Actions exec lib
-
micromark-extension-mdx-md micromark extension to turn some markdown features off for MDX
-
@whatwg-node/node-fetch Fetch API implementation for Node
-
httpxy A full-featured HTTP proxy for Node.js.
-
@azure/core-paging Core types for paging async iterable iterators
-
micromark-extension-mdxjs micromark extension to support MDX.js
-
@babel/helper-environment-visitor Helper visitor to only visit nodes in the current 'this' context
-
resolve-dir Resolve a directory that is either local, global or in the user's home directory.
-
@rollup/plugin-replace Replace strings in files while bundling
-
adler-32 Pure-JS ADLER-32
-
micromark-extension-mdx-expression micromark extension to support MDX or MDX JS expressions
-
@firebase/database This is the Firebase Realtime Database component of the Firebase JS SDK.
-
@azure/core-lro Isomorphic client library for supporting long-running operations in node.js and browser.
-
@shikijs/primitive Tokenizer primitives of Shiki
-
stackblur-canvas Fast and almost Gaussian blur by Mario Klingemann
-
remark-mdx remark plugin to support MDX syntax
-
deprecation Log a deprecation message with stack
-
@oxc-resolver/binding-linux-x64-musl Oxc Resolver Node API
-
yocto-spinner Tiny terminal spinner
-
arr-union Combines a list of arrays, returning a single array with unique values, using strict equality for comparisons.
-
modern-tar Zero dependency streaming tar parser and writer for JavaScript.
-
@tanstack/devtools-event-client TanStack Event Client is a lightweight event client for TanStack Devtools event bus.
-
file-selector Convert DataTransfer object to a list of File objects
-
@xyflow/react React Flow - A highly customizable React library for building node-based editors and interactive flow charts.
-
format printf, sprintf, and vsprintf for JavaScript
-
@graphql-codegen/visitor-plugin-common
-
get-stdin Get stdin as a string or Uint8Array
-
react-dropzone Simple HTML5 drag-drop zone with React.js
-
glob-to-regex.js Transform GLOB patterns to JavaScript regular expressions for fast file path matching.
-
@sideway/formula Math and string formula parser.
-
thunky delay the evaluation of a paramless async function and cache the result
-
@npmcli/git A util for spawning git from npm CLI contexts
-
css-color-keywords A list of all CSS color keywords.
-
conventional-changelog-conventionalcommits Conventionalcommits.org preset for conventional-changelog.
-
@slack/types Shared type definitions for the Node Slack SDK
-
@babel/helper-simple-access Babel helper for ensuring that access to a given value is performed through simple accesses
-
find-up-simple Find a file or directory by walking up parent directories — Zero dependencies
-
@aws-sdk/client-secrets-manager AWS SDK for JavaScript Secrets Manager Client for Node.js, Browser and React Native
-
array-back Guarantees an array back
-
compute-scroll-into-view The engine that powers scroll-into-view-if-needed
-
earcut The fastest and smallest JavaScript polygon triangulation library for your WebGL apps
-
posthog-node PostHog Node.js integration
-
ssh2 SSH2 client and server modules written in pure JavaScript for node.js
-
tsscmp Timing safe string compare using double HMAC
-
css-to-react-native Convert CSS text to a React Native stylesheet object
-
rehype-sanitize rehype plugin to sanitize HTML
-
call-me-maybe Let your JS API users either give you a callback or receive a promise
-
@volar/typescript
-
pretty-error See nodejs errors with less clutter
-
common-ancestor-path Find the common ancestor of 2 or more paths on Windows or Unix
-
@rushstack/eslint-patch Enhance ESLint with better support for large scale monorepos
-
xpath DOM 3 XPath implemention and helper for node.js and the web
-
klona A tiny (240B to 501B) and fast utility to "deep clone" Objects, Arrays, Dates, RegExps, and more!
-
@stripe/stripe-js Stripe.js loading utility
-
jsep A tiny JavaScript expression parser
-
strip-eof Strip the final newline character from a string/buffer
-
esbuild-register Transpile JSX, TypeScript and esnext features on the fly with esbuild
-
metro-core 🚇 Metro's core package.
-
micromark-extension-mdxjs-esm micromark extension to support MDX JS import/exports
-
tinycolor2 Fast Color Parsing and Manipulation
-
@pnpm/npm-conf Get the npm config
-
swagger-ui-dist
-
@electron/get Utility for downloading artifacts from different versions of Electron
-
simple-plist A wrapper utility for interacting with plist data.
Nothing on this page matches. Search all 85,062 technologies.