Go modules
5,000 in Packages and libraries, most used first. Page 2 of 25.
-
github.com/grpc-ecosystem/go-grpc-prometheus
-
github.com/decred/dcrd/dcrec/secp256k1/v4 Package secp256k1 implements optimized secp256k1 elliptic curve operations in pure Go.
-
github.com/Azure/azure-sdk-for-go Package sdk provides Go packages for managing and using Azure services.
-
github.com/gopherjs/gopherjs
-
cloud.google.com/go/storage
-
github.com/xanzy/ssh-agent
-
github.com/dgraph-io/ristretto Ristretto is a fast, fixed size, in-memory cache with a dual focus on throughput and hit ratio performance.
-
github.com/kevinburke/ssh_config Package ssh_config provides tools for manipulating SSH config files.
-
gopkg.in/natefinch/lumberjack.v2 Package lumberjack provides a rolling logger.
-
github.com/opencontainers/go-digest Package digest provides a generalized type to opaquely represent message digests and their operations within the registry.
-
github.com/bytedance/sonic
-
github.com/containerd/continuity
-
github.com/aws/aws-sdk-go-v2 Package sdk is the official AWS SDK v2 for the Go programming language.
-
github.com/Azure/go-autorest/autorest/adal
-
github.com/cespare/xxhash Package xxhash implements the 64-bit variant of xxHash (XXH64) as described at http://cyan4973.github.io/xxHash/.
-
github.com/chenzhuoyu/base64x
-
sigs.k8s.io/structured-merge-diff/v4
-
github.com/go-redis/redis/v8 Package redis implements a Redis client.
-
github.com/jonboulle/clockwork Package clockwork contains a simple fake clock for Go.
-
github.com/kylelemons/godebug
-
github.com/smartystreets/assertions Package assertions contains the implementations for all assertions which are referenced in goconvey's `convey` package (github.com/smartystr
-
github.com/pborman/uuid The uuid package generates and inspects UUIDs.
-
github.com/jackc/pgservicefile Package pgservicefile is a parser for PostgreSQL service files (e.g.
-
github.com/PuerkitoBio/urlesc Package urlesc implements query escaping as per RFC 3986.
-
github.com/armon/go-radix
-
github.com/Azure/go-autorest/autorest Package autorest implements an HTTP request pipeline suitable for use across multiple go-routines and provides the shared routines relied on
-
github.com/jackc/pgpassfile Package pgpassfile is a parser PostgreSQL .pgpass files.
-
github.com/hashicorp/go-plugin The plugin package exposes functions and helpers for communicating to plugins which are implemented as standalone binary applications.
-
github.com/coreos/etcd Package main is a simple wrapper of the real etcd entrypoint package (located at github.com/coreos/etcd/etcdmain) to ensure that etcd is sti
-
go.opentelemetry.io/otel/sdk
-
github.com/containerd/containerd
-
github.com/coreos/go-systemd/v22
-
sigs.k8s.io/controller-runtime Package controllerruntime provides tools to construct Kubernetes-style controllers that manipulate both Kubernetes CRDs and aggregated/built
-
github.com/spaolacci/murmur3 Package murmur3 implements Austin Appleby's non-cryptographic MurmurHash3.
-
k8s.io/apiextensions-apiserver
-
github.com/tidwall/gjson Package gjson provides searching for json strings.
-
github.com/rcrowley/go-metrics Go port of Coda Hale's Metrics library
-
github.com/blang/semver
-
github.com/aws/smithy-go Package smithy provides the core components for a Smithy SDK.
-
github.com/ethereum/go-ethereum Package ethereum defines interfaces for interacting with Ethereum.
-
github.com/go-kit/log Package log provides a structured logger.
-
github.com/denisenkom/go-mssqldb package mssql implements the TDS protocol used to connect to MS SQL Server (sqlserver) database servers.
-
gopkg.in/square/go-jose.v2 Package jose aims to provide an implementation of the Javascript Object Signing and Encryption set of standards.
-
github.com/valyala/fasthttp Package fasthttp provides fast HTTP server and client API.
-
cloud.google.com/go/iam
-
github.com/hashicorp/go-rootcerts Package rootcerts contains functions to aid in loading CA certificates for TLS connections.
-
github.com/urfave/cli Package cli provides a minimal framework for creating and organizing command line Go applications.
-
github.com/hashicorp/go-uuid
-
github.com/gobwas/glob
-
github.com/jmoiron/sqlx Package sqlx provides general purpose extensions to database/sql.
-
gopkg.in/tomb.v1 The tomb package offers a conventional API for clean goroutine termination.
-
github.com/mitchellh/go-testing-interface
-
go.opentelemetry.io/otel/metric
-
github.com/Shopify/sarama Package sarama is a pure Go client library for dealing with Apache Kafka (versions 0.8 and later).
-
github.com/aws/aws-sdk-go-v2/credentials Package credentials provides types for retrieving credentials from credentials sources.
-
github.com/ugorji/go
-
github.com/aws/aws-sdk-go-v2/config Package config provides utilities for loading configuration from multiple sources that can be used to configure the SDK's API clients, and u
-
github.com/go-git/go-git/v5 A highly extensible git implementation in pure Go.
-
github.com/mitchellh/go-wordwrap
-
github.com/tidwall/pretty
-
github.com/huandu/xstrings Package xstrings is to provide string algorithms which are useful but not included in `strings` package.
-
github.com/jackc/pgx/v4 Package pgx is a PostgreSQL database driver.
-
github.com/gogo/googleapis
-
github.com/russross/blackfriday Package blackfriday is a Markdown processor.
-
github.com/coreos/pkg
-
google.golang.org/genproto/googleapis/rpc
-
github.com/hashicorp/consul/api
-
github.com/patrickmn/go-cache
-
github.com/bmizerany/assert
-
github.com/pierrec/lz4 Package lz4 implements reading and writing lz4 compressed data (a frame), as specified in http://fastcompression.blogspot.fr/2013/04/lz4-str
-
k8s.io/klog Package klog implements logging analogous to the Google-internal C++ INFO/ERROR/V setup.
-
github.com/soheilhy/cmux Package cmux is a library to multiplex network connections based on their payload.
-
github.com/moby/term Package term provides structures and helper functions to work with terminal (state, sizes).
-
k8s.io/component-base
-
github.com/bgentry/speakeasy
-
github.com/google/shlex Package shlex implements a simple lexer which splits input in to tokens using shell-style rules for quoting and commenting.
-
github.com/tklauser/go-sysconf Package sysconf implements the sysconf(3) function and provides the associated SC_* constants to query system configuration values.
-
github.com/aws/aws-sdk-go-v2/service/internal/presigned-url Package presignedurl provides the customizations for API clients to fill in presigned URLs into input parameters.
-
github.com/bitly/go-simplejson
-
github.com/nxadm/tail nxadm/tail provides a Go library that emulates the features of the BSD `tail` program.
-
github.com/streadway/amqp Package amqp is an AMQP 0.9.1 client with RabbitMQ extensions
-
golang.org/x/mobile
-
github.com/opencontainers/runc runc is a command line client for running applications packaged according to the Open Container Initiative (OCI) format and is a compliant i
-
gonum.org/v1/gonum Gonum is a set of packages designed to make writing numerical and scientific algorithms productive, performant, and scalable.
-
github.com/envoyproxy/go-control-plane
-
gopkg.in/go-playground/assert.v1 Package assert provides some basic assertion functions for testing and also provides the building blocks for creating your own more complex
-
github.com/btcsuite/btcd/btcec/v2 Package btcec implements support for the elliptic curves needed for bitcoin.
-
github.com/aws/aws-sdk-go-v2/internal/configsources
-
github.com/dlclark/regexp2 Package regexp2 is a regexp package that has an interface similar to Go's framework regexp engine but uses a more feature full regex engine
-
github.com/aws/aws-sdk-go-v2/internal/endpoints/v2
-
github.com/tklauser/numcpus Package numcpus provides information about the number of CPUs in the system.
-
github.com/niemeyer/pretty Package pretty provides pretty-printing for Go values.
-
github.com/go-git/go-billy/v5
-
github.com/hashicorp/serf
-
github.com/dgryski/go-farm
-
github.com/hashicorp/go-sockaddr Package sockaddr is a Go implementation of the UNIX socket family data types and related helper functions.
-
github.com/tmc/grpc-websocket-proxy
-
github.com/coreos/bbolt package bbolt implements a low-level key/value store in pure Go.
-
github.com/dimchansky/utfbom Package utfbom implements the detection of the BOM (Unicode Byte Order Mark) and removing as necessary.
-
github.com/Azure/go-autorest/autorest/date Package date provides time.Time derivatives that conform to the Swagger.io (https://swagger.io/) defined date formats: Date and DateTime.
-
github.com/aws/aws-sdk-go-v2/service/sts
-
github.com/nats-io/nats.go A Go client for the NATS messaging system (https://nats.io).
-
github.com/aws/aws-sdk-go-v2/feature/ec2/imds Package imds provides the API client for interacting with the Amazon EC2 Instance Metadata Service.
-
github.com/Azure/go-autorest/tracing
-
github.com/youmark/pkcs8 Package pkcs8 implements functions to parse and convert private keys in PKCS#8 format, as defined in RFC5208 and RFC5958
-
github.com/hashicorp/vault/api
-
gorm.io/driver/mysql
-
github.com/jackc/pgconn Package pgconn is a low-level PostgreSQL database driver.
-
gopkg.in/warnings.v0 Package warnings implements error handling with non-fatal errors (warnings). A recurring pattern in Go programming is the following: This
-
github.com/aws/aws-sdk-go-v2/service/sso
-
go.etcd.io/etcd Package main is a simple wrapper of the real etcd entrypoint package (located at github.com/coreos/etcd/etcdmain) to ensure that etcd is sti
-
github.com/xdg-go/scram Package scram provides client and server implementations of the Salted Challenge Response Authentication Mechanism (SCRAM) described in RFC-
-
github.com/go-git/gcfg Package gcfg reads "INI-style" text-based configuration files with "name=value" pairs grouped into sections (gcfg files).
-
github.com/grpc-ecosystem/grpc-gateway/v2
-
github.com/Azure/go-autorest/logger
-
github.com/evanphx/json-patch/v5
-
github.com/Masterminds/goutils Package goutils provides utility functions to manipulate strings in various ways.
-
github.com/elazarl/goproxy Package goproxy provides a customizable HTTP proxy, supporting hijacking HTTPS connection.
-
github.com/cloudflare/circl Package circl provides a collection of cryptographic primitives.
-
gopkg.in/mgo.v2 Package mgo offers a rich MongoDB driver for Go.
-
github.com/gophercloud/gophercloud Package gophercloud provides a multi-vendor interface to OpenStack-compatible clouds.
-
github.com/lucas-clemente/quic-go
-
github.com/jackc/pgproto3/v2 Package pgproto3 is a encoder and decoder of the PostgreSQL wire protocol version 3.
-
github.com/shurcooL/sanitized_anchor_name Package sanitized_anchor_name provides a func to create sanitized anchor names.
-
github.com/jackc/pgio Package pgio is a low-level toolkit building messages in the PostgreSQL wire protocol.
-
github.com/ulikunitz/xz Package xz supports the compression and decompression of xz files.
-
github.com/alecthomas/units Package units provides helpful unit multipliers and functions for Go.
-
github.com/xdg-go/stringprep Package stringprep provides data tables and algorithms for RFC-3454, including errata (as of 2018-02).
-
github.com/klauspost/cpuid Package cpuid provides information about the CPU running the current program.
-
github.com/PuerkitoBio/goquery Package goquery implements features similar to jQuery, including the chainable syntax, to manipulate and query an HTML document.
-
github.com/Masterminds/semver Package semver provides the ability to work with Semantic Versions (http://semver.org) in Go.
-
github.com/agext/levenshtein Package levenshtein implements distance and similarity metrics for strings, based on the Levenshtein measure.
-
github.com/prometheus/tsdb Package tsdb implements a time series storage for float64 sample data.
-
filippo.io/edwards25519 Package edwards25519 implements group logic for the twisted Edwards curve
-
github.com/xiang90/probing
-
github.com/aliyun/alibaba-cloud-sdk-go This file is created for depping ensure.
-
github.com/go-logr/zapr Package zapr defines an implementation of the github.com/go-logr/logr interfaces built on top of Zap (go.uber.org/zap).
-
github.com/jinzhu/gorm
-
github.com/xdg-go/pbkdf2 Package pbkdf2 implements password-based key derivation using the PBKDF2 algorithm described in RFC 2898 and RFC 8018.
-
github.com/jackc/chunkreader/v2 Package chunkreader provides an io.Reader wrapper that minimizes IO reads and memory allocations.
-
github.com/google/s2a-go Package s2a provides the S2A transport credentials used by a gRPC application.
-
github.com/jackc/pgtype
-
github.com/Masterminds/semver/v3 Package semver provides the ability to work with Semantic Versions (http://semver.org) in Go.
-
github.com/aws/aws-sdk-go-v2/internal/ini
-
github.com/bradfitz/gomemcache
-
github.com/morikuni/aec
-
github.com/twitchyliquid64/golang-asm
-
github.com/mitchellh/hashstructure
-
github.com/nats-io/nats-server/v2
-
github.com/kisielk/errcheck
-
github.com/hashicorp/go-msgpack
-
github.com/deckarep/golang-set Package mapset implements a simple and generic set collection.
-
gopkg.in/src-d/go-git.v4 A highly extensible git implementation in pure Go.
-
gopkg.in/go-playground/validator.v9 Package validator implements value validations for structs and individual fields based on tags.
-
github.com/hashicorp/yamux
-
github.com/go-task/slim-sprig Sprig: Template functions for Go.
-
github.com/posener/complete Package complete provides a tool for bash writing bash completion in go, and bash completion for the go command line.
-
github.com/nats-io/nuid A unique identifier generator that is high performance, very fast, and tries to be entropy pool friendly.
-
github.com/fatih/structs Package structs contains various utilities functions to work with structs.
-
github.com/docker/cli
-
github.com/cloudflare/cloudflare-go Package cloudflare implements the Cloudflare v4 API.
-
github.com/NYTimes/gziphandler
-
gotest.tools Package gotesttools is a collection of packages to augment `testing` and support common patterns.
-
golang.org/x/arch
-
github.com/chzyer/readline Readline is a pure go implementation for GNU-Readline kind library.
-
github.com/xeipuuv/gojsonschema
-
github.com/jbenet/go-context Package context contains some extenstions to go.net/context by @jbenet
-
github.com/tidwall/match Package match provides a simple pattern matcher with unicode support.
-
github.com/dgraph-io/badger/v2 Package badger implements an embeddable, simple and fast key-value database, written in pure Go.
-
github.com/hashicorp/vault/sdk
-
github.com/DataDog/datadog-go
-
github.com/labstack/gommon
-
github.com/onsi/ginkgo/v2 Ginkgo is a testing framework for Go designed to help you write expressive tests.
-
github.com/garyburd/redigo
-
k8s.io/gengo
-
github.com/ryanuber/go-glob
-
github.com/nats-io/nkeys Package nkeys is an Ed25519 based public-key signature system that simplifies keys and seeds and performs signing and verification.
-
github.com/xeipuuv/gojsonpointer
-
github.com/go-chi/chi/v5 Package chi is a small, idiomatic and composable router for building HTTP services.
-
github.com/cyphar/filepath-securejoin Package securejoin implements a set of helpers to make it easier to write Go code that is safe against symlink-related escape attacks.
-
github.com/bwmarrin/discordgo Package discordgo provides Discord binding for Go
-
github.com/kr/pty Package pty is a wrapper for github.com/creack/pty, which provides functions for working with Unix terminals.
-
github.com/andybalholm/cascadia Package cascadia is an implementation of CSS selectors.
-
github.com/oxtoacart/bpool Package bpool implements leaky pools of byte arrays and Buffers as bounded channels.
-
github.com/coreos/go-oidc Package oidc implements OpenID Connect client logic for the golang.org/x/oauth2 package.
-
github.com/gocql/gocql Package gocql implements a fast and robust Cassandra driver for the Go programming language.
-
github.com/zclconf/go-cty
-
github.com/influxdata/influxdb Package influxdb is the root package of InfluxDB, the scalable datastore for metrics, events, and real-time analytics.
-
github.com/godbus/dbus Package dbus implements bindings to the D-Bus message bus system.
-
github.com/acomagu/bufpipe Package bufpipe provides a IO pipe, has variable-sized buffer.
-
contrib.go.opencensus.io/exporter/ocagent
-
github.com/valyala/fasttemplate Package fasttemplate implements simple and fast template library.
-
github.com/labstack/echo/v4 Package echo implements high performance, minimalist Go web framework.
-
github.com/alecthomas/template Package template implements data-driven templates for generating textual output.
-
github.com/gofiber/fiber/v2 Package fiber is an Express inspired web framework built on top of Fasthttp, the fastest HTTP engine for Go.
-
github.com/go-chi/chi Package chi is a small, idiomatic and composable router for building HTTP services.
-
github.com/boombuler/barcode
-
github.com/aliyun/aliyun-oss-go-sdk
-
github.com/benbjohnson/clock
-
github.com/ProtonMail/go-crypto